This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 2 replies, has 2 voices.

Last updated by carolaI 8 months ago.

Assigned support staff: Bruno.

Author Posts
September 19, 2019 at 5:37 pm #4607721


first: this documentation does not help me:
To Translate Block 1) Go to Translation management->Multilingual content setup -> Custom posts and set the blocks to be translated. 2) Now go to blocks and translate it accordingly in secondary languages.

I cant find it!
I am using theme flatsome with UX Blocks. I defined the footer with UX blocks and translated it. The block ist referred with shortcode. Now going on the (start) page in english the footer does not show at all, although it is translated. hidden link

Thank you and kind regards from Germany,

September 21, 2019 at 7:36 am #4615515


Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)


Thank you for contacting us. I am not sure where you took these steps (maybe some older post), but I believe you should follow these steps to test:

- Click on the WPML > Settings > Post Types Translation
- Set the desired option (for example, blocks) to be translatable.
- Now go to blocks and translate it accordingly in secondary languages.

By following these steps, can you make this custom post translatable?

Thank you.

September 24, 2019 at 2:28 pm #4632465


my issue is resolved now but in a different way by myself:

Normal Flatsome-UX-blocks could be translated in the usual way (as you wrote).

The Footer and f.e. the topbar were definied by html-code in the flatsome customizer. Since there was no option to translate I had to replace the html-code in the customizer with UX blocks, which I then could translate.

Thanks for your assistance and kind regards,