Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 22 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 2 weeks, 6 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
December 17, 2019 at 8:18 am #5144179

alexanderA

Hello. I created a ticket a few weeks ago, and it was unfortunately closed before I could respond (https://wpml.org/forums/topic/issue-with-elementor-plugin-and-wpml-language/page/2/). I posted a follow-up comment, but no WPML staff member seems to receive a notification--so no one replies. I'm hoping someone can reply here and we can continue the discussion.

Thanks.

December 19, 2019 at 6:36 pm #5165717

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, refer to my reply at: https://wpml.org/forums/topic/issue-with-elementor-plugin-and-wpml-language/page/3/#post-5165715. As we are dealing with your request in an already created ticket, this one will be closed to keep our forum organized on a topic basis. Thank you for your understanding an collaboration, have a nice day.

December 22, 2019 at 4:44 am #5177381

alexanderA

>> Please, refer to my reply at: https://wpml.org/forums/topic/issue-with-elementor-plugin-and-wpml-language/page/3/#post-5165715. As we are dealing with your request in an already created ticket, this one will be closed to keep our forum organized on a topic basis.

I would LOVE to continue the discussion in https://wpml.org/forums/topic/issue-with-elementor-plugin-and-wpml-language/page/3/#post-5165715. But every time I reply, you IGNORE it. We've established that since that ticket is closed, you do not receive an email notification. So in light of that, I would like to continue the discussion in a non-closed ticket, like this ticket, or https://wpml.org/forums/topic/follow-up-on-ticket-3/. Is that possible?

December 23, 2019 at 4:45 pm #5185819

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Yes, it is possible you can continue the discussion in the ticket at: https://wpml.org/forums/topic/follow-up-on-ticket-3/. I just want to mention both me and Jamal already replied your question, Elementor on its latest version makes it possible to keep the admin language in the frontend editing, as this was your question and request before, I assume it is already solved, right?

My answer to your question: https://wpml.org/forums/topic/issue-with-elementor-plugin-and-wpml-language/page/3/#post-5165715

Jamal's answer: https://wpml.org/forums/topic/issue-with-elementor-plugin-and-wpml-language/page/3/#post-5165715

Hope it helps, have a nice day.

January 1, 2020 at 11:28 am #5218927

alexanderA

>> I've just installed a recent version where they seem to have fixed the issue and made Elementor loads the admin language in the frontend interface regardless the language being used, you can confirm it here: hidden link

I checked that test site, and I still see the same issue. Namely, the WPML language is Spanish, and the Elementor controls are still in Spanish (screenshots: hidden link). The Elementor controls need to be in English. Am I misunderstanding something? Also, I can no longer login to that test site you created. So, were you able to fix the issue or not?

January 14, 2020 at 2:35 pm #5290619

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Sorry for the bit of waiting here, I was on vactions and your ticket get lost in someway. The spanish language for the elementor controls in the sample website are due the fact the admin language in the WordPress Dashboard is also set as spanish, in other words the issue is solved with Elementor, whatever language you have set as the admin language will be the language the Elementor interface will be displayed in.

The test website has an expiration date, so in this case it is expired, you can confirm the fixes provided by Elementor on your own, update to its latest versions and then load Elementor in the frontend in order to see it. Hope it helps, have a nice day.

January 15, 2020 at 9:16 am #5295871

alexanderA

Marcos,

You don't seem to be understanding my issue. Here is why I say that.

In your most recent reply you said,

>> in other words the issue is solved with Elementor, whatever language you have set as the admin language will be the language the Elementor interface will be displayed in.

If you read my original post about this issue, (https://wpml.org/forums/topic/issue-with-elementor-plugin-and-wpml-language/), I've said that I already set my admin language to "English." But when I change the WPML language (in the admin bar) to Chinese, the Elementor controls are displayed in Chinese. Are you saying that on the test site you linked, that issue does *not* occur? If so, can you link a new site in which that issue does not occur?

January 15, 2020 at 2:32 pm #5298471

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I created another test site and confirmed the issue is indeed resolved, please proceed like this:

1 - Click to login in the test site using this one click login url: hidden link

2 - Go to WordPress Dashboard > Users > Your Profile > Personal Options > Language and set your prefered language for your user.

3 - Go to WordPress Dashboard > Pages and click to edit the 'Test Page EN', then click to edit it using Elementor, noticed the Elementor interface texts will be displayed in your chosen language from the step 2 above.

4 - Now, click to display the 'Test Page ES' (the translation of 'Test Page EN') then click to edit the page using Elementor, you will notice the Elementor interface texts will be still in the language chosen in the step 2.

In summary, as said this issue is solved in the most recent version of Elementor, make sure it is updated in your website, both Elementor and WPML, also make sure you don't have any browser cache, WordPress plugin cache running and so on.

Please, let me know if you need any other detail, have a nice day.

January 17, 2020 at 10:23 am #5310687

alexanderA

I was able to carry out step 1, but not step 2. When I opened Users-->Your Profile, the page read, "You don't have permission to access this page" Thoughts?

Anyway, I continued testing on that site, and actually was able to see that the issue is no longer present there. My site is currently running Elementor v2.8.2, and the latest version is version 2.8.2. Give me a day or two to try updating and see if the issue is gone. I'll report back here then.

Thanks.

January 17, 2020 at 12:37 pm #5311877

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. The step 2 of my instructions is only relevant in order to experiment with different languages for your user profile and see Elementor to load the interface text and description in the chosen language regardless of the frontend language. Maybe we have a permission issue in the test website, please update to Elementor latest version in your website and make the required tests, then let me know if it works for you, have a nice day.

January 18, 2020 at 10:35 am #5315553

alexanderA

OK I updated Elementor to v2.8.3, but the issue is still present. Here are screenshots showing the Elementor controls on the EN page, and the Elementor controls on the FR page: hidden link

Thoughts?

January 20, 2020 at 4:27 pm #5325851

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, provide me with the access details for your website where the issue is found. As it is not reproduced in a clean install we have an issue specific for your website and server environment only which the cause should be investigated. I will mark the next reply as private, so you can safely provide these access details, thank you for your collaboration and patience, have a nice day.

January 21, 2020 at 7:40 pm #5335723

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I confirmed the issue keeps happening in your particular case even with the most recent version of Elementor, as the issue is particular to your website, most likely a third party plugin or even your theme might be interfering in the proper functionality introduced in the most recent versions of Elementor. Please, try the following troubleshooting:

1 - Disable all the plugins except WPML related ones and Elementor itself and test the Elementor in your website frontend again, if it works activate one plugin at a time untill the culprit one is found.

2 - If the issue persists, change to a default WordPress theme from your WordPress Dashboard > Appearance > Themes settings and try the Elementor in your website frontend again.

Please, let me know if it fixes your issue, have a nice day.

January 25, 2020 at 10:25 am #5361221

alexanderA

OK let me try that. Give me a few days. But in the meantime, did you install the plugin "WP File Manager" on my site (screenshot: hidden link)?

Thanks.

January 27, 2020 at 12:20 pm #5369783

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. No, it wasn't installed by our support staff. Please, let me know when you are ready with the tests provided in my previous reply. Thank you for your collaboration, have a nice day.