This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 1 reply, has 2 voices.

Last updated by Bruno Kos 11 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
June 17, 2019 at 2:58 pm



This is a follow up to support thread post #3779533 [Divi Modules Disappear After Translation].

I had sent in a ticket regarding my Divi modules disappearing. The support agent, Andreas W., explained that this was due to my content not being translated into Spanish. I had someone translate my posts into Spanish, and now while the text shows, the images do not. I've also already raised my PHP values.

Would you be able to provide support, please?

June 18, 2019 at 10:36 am #4042713

Bruno Kos

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)


Thank you for contacting WPML support!

I have checked that thread:

So the only issue now is that images don't show up in those blog posts elements? From what I see, "et_pb_image_container" field is not appearing on translations, but this is because no featured image or any images for that matter were added into translations. Therefore, this will need to be fixed manually for each post. Both "Duplicate uploaded media to translations" and "Duplicate featured image to translations" were unchecked for some reason while creating translations.

Therefore, this would need to be done for all of them and it should fix the issue within the post lists. This would be a tutorial on how to do this:
- open original such as hidden link
- edit
- Mark both "Duplicate uploaded media to translations" and "Duplicate featured image to translations within Media attachments
- check the featured image ( if not set already or if not the correct version)
- update
- open translation, mark those two fields ( as per my screenshot) as translated and save
- the translation should now pick up the featured image, which should also appear in the blog section of the homepage of the translated page

Let me know how it goes or if this resolves it!

Bruno Kos