Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to have the language switch show my alternate language (2 language site at present)

Solution: The cause that you don't see the secondary language in the homepage is that its translation is not finished yet. The translation of this page was sent to a translation service called 'Espresso Translations' and they haven't finished the translation yet.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Carlos Rojas 2 years, 5 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 14, 2019 at 8:28 am #4019299

stueyP

I am trying to: have the language switch show my alternate language (2 language site at present)

Link to a page where the issue can be seen: hidden link

I expected to see:Both English and Indonesian flags and descriptions in the main menu

Instead, I got: Only the English language switch option. I tried to change to drop down option and also footer switches but again I only get one switch in each location.

Language switcher.JPG
June 14, 2019 at 9:05 am #4019811

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
Thank you for contacting WPML support.

1.- Please make sure the content is translated correctly and visit this link where you will be able to our official documentation regarding language switcher configuration: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Please let me know if you need further assistance.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

June 15, 2019 at 2:19 am #4024773

stueyP

Hi Carlos,

Thank you for your explanation, I however am still having issues with the secondary language switch not showing. I have followed the set up procedure correctly (as far as I can see) and all the information I have read states that the the Woocommerce theme I am using (Storefront) is compatible with WPML. Also I have no experience using php coding so I am not confident to try entering the details you gave me to increase the memory allocation. Is it possible to provide you access to my site admin to have you look into these issues and make the necessary changes?

June 17, 2019 at 8:52 am #4033471

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Best regards,
Carlos

June 18, 2019 at 11:11 am #4043065

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,
Thank you very much for the information provided.

I was able to visit the site. The cause that you don't see the secondary language in the homepage is that its translation is not finished yet. The translation of this page was sent to a translation service called 'Espresso Translations' and they haven't finished the translation yet.

As a demonstration I manually translated the Sample Page and you can see it working properly in this link: hidden link

Once the translation service finishes the translation then it will be available in your site 🙂

Regards,
Carlos

June 18, 2019 at 4:05 pm #4045081

stueyP

Carlos,

Thanks for the assistance. Were you able to adjust the memory allocation for my site also?

June 18, 2019 at 9:59 pm #4046707

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,

I'm sorry, I forgot to tell you that I increased the memory already 🙂

Please let me know if you need further assistance and I will be more than happy to help.
Best regards,
Carlos

June 19, 2019 at 2:47 am #4047375

stueyP

My issue is resolved now. Thank you!

June 19, 2019 at 5:25 am #4048021

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos

June 21, 2019 at 7:40 am #4065283

stueyP

Hi Again Carlos,

Not sure if you can assist me again through this or if I need to open a new ticket. Since I last communicated with you, I have sent my home page and 2 product pages to a translation service and they have completed the translation and returned them. Initially I was able to access the Indonesian version of the home page without issue but I found that the sample page you set up was showing up in the Indonesian main menu, so I set that page to draft and since then I can't access any translated pages. I am really confused as to what is happening. From the WP backend if I try to access my home page view the url comes up with .com/all now which it never had before, but only in the back end. Let me know if you can assist me or not. Thanks

June 21, 2019 at 8:13 am #4065409

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,
Thank you very much for contact us again.

As this ticket is closed already I kindly ask you to open a new ticket describing the situation and assign it directly to me.

I will be more than happy to keep assisting you.
Regards,
Carlos