This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Shekhar Bhandari 5 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 7, 2019 at 3:24 am #3753715

chrisC-37

The text formatting is not applied for the "field-top_description", its small and blank, instead of larger and white.

hidden link

May 7, 2019 at 3:43 am #3753763

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have seperated this issue from that ticket as it will be easier to discuss issues easily. I hope that's ok. 🙂

I can see the issue for the translation of this text, "With its deep technology expertise, RSi enables CPG manufacturers to transform their huge volumes of data into knowledge, and then into actionable insights, helping them to make better, faster, more profitable decisions."

This is happening because the <p> tags aren't added properly in the translation and I can replicate this behavior on a fresh install. Is this the only issue? If there are any other places where there are no spaces added properly, could you please add a screenshot and show us so I can escalate all the issues at once?

As a workaround, could you please go to wp-content/themes/rsiorg/blocks/top.php line no.6 and replace it with

<p><?php the_field('top_description'); ?></p>

Does this help?

Look forward to your reply.

Thanks

May 8, 2019 at 11:44 am #3766169

chrisC-37

These issues are happening on all the pages where there are paragraphs are missing, and font information missing.

See ScreenShot 1 showing this page as an other example of missing <p>: hidden link

Also on the same page the Font Formatting is missing too. See screen shot where the Chinese "field-top_description" is in a different colour and smaller.

May 8, 2019 at 11:56 am #3766343

chrisC-37

Can we do a screen share, I feel this would be the best way to solve this issue. I can send you a GoToMeeting Invite in a private post. Thanks.

May 8, 2019 at 12:11 pm #3766475

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am sorry, but it's not possible to use some services like "GoToMeeting" for forum purpose.

But, you can record a video and share it along with me, this will work.

In the meantime, Did you tried the workaround suggested in the previous reply.

Thanks

May 8, 2019 at 12:15 pm #3766493

chrisC-37

Hi Shekhar, no, not yet, since this issue is effecting all pages it seems, so just fixing it here for one page or theme area won't fix the issue everywhere. The translated pages are also missing font formatting. I would rather we investigate the cause of the issue as this would fix all the issues, than trying to implement a workaround fix that would need to be done for every issue.

May 8, 2019 at 12:18 pm #3766527

chrisC-37

The reason I asked for a GoToMeeting is just to speed up the communication, as this question and answer on the forum is really painfully slow, and we sometimes miss each other due to time difference. I'm sure if we have a quick 15 min share screen we could probably sort this out. Anyway I understand your forum rules and guidelines prevent this. Is there another paid support avenue that I can access through WPML?

May 8, 2019 at 12:32 pm #3766613

chrisC-37

In the mean time, if you just look at the site with the login credentials I sent you previously, and filter for all the Chinese translated pages, about 20, and open a few of them and compare with the English, you will see what I mean.
1) Whole paragraphs are missing font formatting, especially in the title description areas.
Also some bullet type marks "»" are in green in source but are standard colour in Chinese.
2) <p> marks seem to be missing in all pages
3) Section Titles seem to be missing translations.
I also noticed these Section sub field items are not Marked for Translation, yet the "Content" was translated. I don't understand, should they all be marked for translation. How come some fields were translated and not marked for translation.
See screen shots, all section sub fields were not marked for translation, but the "Content" field still got translated, but the "Title" did not. See screen shots.

I just don't understand what's going on here, the whole translation process seems to be inconsistent. I just want to know what can we do to make all the pages appear translated, with all appropriate sections and sub files translated, and all <p> and font formatting applied correctly.

Thanks,
Anthony.

May 9, 2019 at 5:36 am #3773185

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I debugged the issue further and noticed that you have enabled the "Automatically Add Paragraphs" for new links in custom fields settings, since field settings are saved in _custom_field_name, to fix the issue please follow the below steps:

- Go to Page editor
- Go to Multilingual content setup
- Click on "show system links"
- Mark the fields that you have enabled to add "automatically add paragraphs" to copy

For example, I marked the _top_description as copy and the font information and spacing is working perfectly here:
hidden link

Regarding the bullet list, I couldn't find an reference to it, could you please provide a link where the issue can be seen?

I also noticed these Section sub field items are not Marked for Translation, yet the "Content" was translated. I don't understand, should they all be marked for translation. How come some fields were translated and not marked for translation.
See screen shots, all section sub fields were not marked for translation, but the "Content" field still got translated, but the "Title" did not. See screen shots.

It seems like the settings are not synchronized, I request you to refer to page editor -> Multilingual content setup fields settings and see if they are set as translatable?

I understand that it's taking a bit more time to resolve all these issues, to make things resolved quickly I request you to open separate tickets for each issue, so more supporters can work on the same time for several issues.

Look forward to your reply.

Thanks

May 9, 2019 at 8:08 am #3774005

chrisC-37
I debugged the issue further and noticed that you have enabled the "Automatically Add Paragraphs" for new links in custom fields settings, since field settings are saved in _custom_field_name, to fix the issue please follow the below steps:

Where are you seeing this? Can you show me a screen shot please so I know where to look for this setting next time this happens.

- Mark the fields that you have enabled to add "automatically add paragraphs" to copy

How do I know which fields have "automatically add paragraphs" setting enabled?

Regarding the bullet list, I couldn't find an reference to it, could you please provide a link where the issue can be seen?

Here you can see the bullet list markers (not real bullets) have green colour font. But the Chinese page has normal colour font.

hidden link

By the way, I can't find the Page Editor, can you show me a screen shot of how to get to this.

Thanks for all your help here, I think we are almost getting everything sorted.

Cheers,
Anthony.

May 9, 2019 at 8:24 am #3774119

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have attached 2 screenshots below, I hope it helps.

By the way, I can't find the Page Editor, can you show me a screen shot of how to get to this.

I am not sure what are you referring to as Page Editor here, are you trying to edit the page or are you talking about the translation editor.

Here you can see the bullet list markers are in green (not real bullets). But on the Chinese page there are normal colour.

<em><u>hidden link</u></em>

In the default language, the bullets are being added using "<span>»</span>" and the color is applied using this span element, so could you also use the same <span> element on the translation, this will get the same results.

I noticed that you are not using Advanced translation editor, and I couldn't see any translation there (are you doing some changes) In ATE you can easily parse the span class HTML marker as it's highlighted.

Let me know if this helps.

Thanks

May 9, 2019 at 9:06 am #3774377

chrisC-37

In relation to the Page Editor. In your previous instructions you said to go to the "Page Editor". So I was confused what you meant when you said Page Editor. I know now what you mean now though.

In regards to the missing Span tags for the bullets. These are already in our translated XML file, see screen shot. So can you see why this is not being displayed?

May 9, 2019 at 9:32 am #3774675

chrisC-37

I resent the page out for translation to the basket, and translated it from our TM and sent it back to WordPress. I downloaded the translations and the Span tags are now visible. So that fixed the issue. I wonder how they were removed in the first place.

Anyway, I still have the issue where the Paragraph marks are not being kept after the file is translated, please take a look.

hidden link

Thanks.

May 9, 2019 at 10:08 am #3774973

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

This is happening because you are using enter breaks on the text tab of the editor, to fix this please follow the below steps:

- Go to the page editor
- On the content tab, remove all unwanted spaces or wrap them with <p> tags
- You can also go to the visual tab and press enter, it will auto enter the <p> tags, once <p> tags are added you can translate the content, this will fix the issue.

Let me know if this helps.

Thanks

May 9, 2019 at 1:52 pm #3776719

chrisC-37

Thanks, this will be a bit of work then for our client to Retro fix.
I'm checking with out Translation Software support to see if they can do something here.

So before we close this ticket, for future projects I'm still unsure of how to know when we should set some custom fields as "Copy" and some as "Translate". Should every fields be set to copy by default as a starting point, and then mark the ones with Text to Translate?

Cheers,
Anthony.