This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 33 replies, has 2 voices.

Last updated by Bigul 3 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
May 21, 2019 at 8:53 am #3853329

briceB-3

I am trying to: traduce the footer credits in the divi theme. The problem in that after apply the traduction, it works well during 1 or 2 hours. I have the french version on the french pages and the english version on the english pages. It's ok.

But after, wpml apply the traduction on the french pages and the english pages. Why ?

Link to a page where the issue can be seen: hidden link

I expected to see: Contact - Plan du site - Conditions générales de ventes - Conditions générales d'utilisations

Instead, I got:Contact - Site Plan - General conditions of sale - General conditions of use

May 21, 2019 at 12:32 pm #3855131

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Recreate ST DB cache tables

--
Thanks!

Bigul

May 21, 2019 at 2:39 pm #3856245

briceB-3

Hello,

I have apply your process but it does not work. Exactly the same problem.

May 21, 2019 at 5:24 pm #3857705

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

May 23, 2019 at 12:38 pm #3875033

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. This may be happening because *FOOTER CREDITS* field is showing the English texts in theme customizer. Please change it back to French and check you are getting the expected result or not.

Please check the attached image for more details.

--
Thanks!

Bigul

May 23, 2019 at 2:03 pm #3876239

briceB-3

Hello,

Yes I know that. But if I change in French, some minutes after, it becomes in english. It's the problem. Try it.

May 24, 2019 at 7:44 am #3881907

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following steps after a site backup and check you are getting the expected result or not.

1) Delete the *custom_footer_credits* string from WPML>>String Translation
2) Go to WPML>>Support>>Troubleshooting page and click on following options

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Recreate ST DB cache tables

3) Add the French footer credits from theme customizer
4) Translate it to English

--
Thanks!

Bigul

May 24, 2019 at 8:11 am #3882131

briceB-3

Hello,

I have proceed that you told me. It does not work. Exactly 4mn after make it, the french version becomes in english.

May 24, 2019 at 2:30 pm #3885639

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have a couple of requests to track the issue.

1) Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Deactivate all the plugins that are not related to WPML
c) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

2) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

May 28, 2019 at 7:09 am #3903205

briceB-3

Hello,

After one day of trials it appears that I haven't find any conflict with another plugin. Always, the french traduction of the footer becomes en english.
In the debug log, there are no message too.

Thanks in advance for your help.

May 28, 2019 at 11:29 am #3906253

briceB-3

Hello,

After some other investigation, it appears that it's an incompatibility with Ultimate member plugin that cause the problem. But in the debug log, they have nothing.

May 28, 2019 at 6:31 pm #3909375

briceB-3

Hello, thanks for the sandbox. But, I can't upload my divi theme because it's automatically include with my wordpress installation. Another solution ?

May 29, 2019 at 9:06 am #3913723

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the update. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

May 29, 2019 at 9:14 am #3913773

briceB-3

Hello,

it's ok, I have installed duplicator. Thanks for your help.

May 30, 2019 at 7:43 am #3921007

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a Duplicator copy of your site. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

The topic ‘[Closed] Footer credits traduction does not stay’ is closed to new replies.