This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by alexanderP-47 3 weeks, 3 days ago.

Assigned support staff: Bruno.

Author Posts
September 13, 2019 at 10:39 am #4567533

alexanderP-47

If I go to our startpage and change the language into English the footer is still shown in German. Is I go the the site settings to change the footer and choose the english one as it is done by the others it doesn´t work. It shows that there is another footer connected "disable footer" to the english page and I don´t know how to change that.

September 13, 2019 at 9:55 pm #4570905

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. It depends on how your theme was made. This option seems to be being set globally - so I believe the fields are disabled.

How are these options set? Is this a plugin or is it a feature of your theme? If there is a global page to edit this option, have you tried changing to the secondary language using the top bar selector to edit this option?

Thanks.

September 16, 2019 at 10:34 am #4578883

alexanderP-47

Hi Bruno,

it is strange I can´t change any setting. I already was going trough everything I knew. But I am not that specialist. I don´t know why the setting for all other things are clear but not for the starting page. What makes that differ?

September 16, 2019 at 10:25 pm #4584449

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

For this option, there is no global setting? I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

September 20, 2019 at 6:29 am #4609999

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I fixed the footer issue on your site. I followed the steps below:

- Copy the footer.php to the child theme;
- On the child theme, I edited the footer.php file and added this line:

$footer = apply_filters( 'wpml_object_id', $footer, 'footer' );

- Note that the changed footer.php is in the child theme directory.

After that, the footer was displayed correctly. Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

September 20, 2019 at 7:21 am #4610163

alexanderP-47

My issue is resolved now. Thank you!