We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by alexanderP-47 6 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
April 16, 2019 at 9:16 am

alexanderP-47

I am trying to: Have in a blog the tranlated footer

Link to a page where the issue can be seen:hidden link

I expected to see: the footer

Instead, I got:just the copyright hint without the normal tranlated footer

April 16, 2019 at 11:45 am
April 16, 2019 at 5:12 pm #3624235

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi there,

-I came up with a workaround for you so about this issue. basically you just need to set the default footer option in your theme options to the footer you want to use.

-In the post you're about to translate, you'll then change the footer option to "default theme option" (which is in the meta page section).

-then you'll register the footer layout following the documentation below:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

I already did that for you on the sandbox site and the code is the following one:

<wpml-config>
    <admin-texts>
        <key name="winnex_theme_options">
            <key name="footer_layout"></key>
        </key>
    </admin-texts>
</wpml-config>

So what you need to do now, is copy this code and paste it in your site, by going to WPML > Settings > Custom XML Configuration.

-Afterwards, go to WPML > String Translation and proceed to translate the ID of the string that just appeared with the ID of the footer of the translated language.

I created a video so you have a better grasp of what i did and so you don't get lost in the process: https://www.loom.com/share/f98d097cd60b47e199f82bd64f580521

Please let me know f you have any doubt regarding this issue.

April 18, 2019 at 6:55 am #3636431

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I am escalating this ticket for further testing on multiple footer settings.

You do not need to answer this ticket, i'll let you know over here if i get any updates.

April 18, 2019 at 10:35 am #3638309

alexanderP-47

Hi,

I can´t find the sting in the string translation. I´ve checked the strings on admin screen, the footer is already ticket. I can´t find them afterwards in the sting translations to change the number. The only thing I can find is in the picture below.

April 19, 2019 at 3:35 pm #3647071

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I checked your site and the footer string wasn't there because the code i sent above was not added to your site, the default footer code wasn't added to your theme options (you had to select "footer 1") and lastly the right option wasn't set in your trouble post (you had to select "default theme footer).

I went ahead and did it for you, as i did the entire process i mentioned above and now the footer is showing correctly.

Regards.

April 24, 2019 at 11:18 am #3672033

alexanderP-47

Hi,

the footer is still incorrect. Now the german footer is in english and the english footer in german. Can you help to solve that. At this page hidden link the footer is german and on the german page hidden link the footer is in english.

Regards

April 24, 2019 at 4:12 pm #3675035

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

Please find the string in WPML > String Translation (as shown in the video) and then just change the language of said string (select it and then scroll down and press the button: "Change language of selected strings")

That should do it.

Regards.

April 25, 2019 at 10:16 am
April 26, 2019 at 3:33 pm #3692031

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I just checked my sandbox environment where i reproduced this and in there the problem is not happening. i renamed your footer just so i could know if it was assigning the right one and it seems it does in a way, but it always show the English one in the theme settings > Footer.

I believe there is a server-side cache on your server because the changes on the front-end seem static and out of nowhere they change (it was showing the correct one in each language right before i wrote this message), plus this problem is not being reproduced on the sandbox site and i tested that there wasn't any conflict plugin as well.

in the sandbox everything's fine, in the site it isn't, so the only thing that we can't rule out is the server. please ask your hosting support if they have a server-side caching System. if they do, please ask them to disable it or flush it.

Let me know how it goes.

P.S: if you want to check the sandbox site, this is the link: hidden link

April 28, 2019 at 1:32 pm #3698131

alexanderP-47

My issue is resolved now. Thank you!