This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by sandraG-26 1 month, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 27, 2019 at 5:38 pm #4468759

sandraG-26

My website is built with OceanWP theme and Elementor.
I did a custom footer which is choosen in the Theme Customizer, and it is registered in the Theme Panel/My Library of OceanWP.
This custom header is build with Elementor and I translated it using the WPML Translation Editor. The translated footer does not appear in the second language. The original footer keeps appearing in all the pages but not the translated footer. I checked the forum for solutions, but none worked. Please advise on this matter.

August 27, 2019 at 7:11 pm #4469203

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 27, 2019 at 7:39 pm #4469457

sandraG-26

I clicked reply, but I do not see the fields that I need to fill out. Also, how I make sure this is going to be private?

August 27, 2019 at 7:44 pm #4469465

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, confirm if you see the fields now, I have renabled the private reply fields for you. Thank you for your collaboration, have a nice day.

August 28, 2019 at 4:30 pm #4475921

sandraG-26

Hi, I sent you the information you requested. Could you please process my request asap? Thanks

August 28, 2019 at 5:14 pm #4476121

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the bit of waiting here. I took a detailed look and noticed you didn't transalate your footer customizer field to show your translated footer in your translated pages. Here is what I tried:

1 - In your WordPress Dashboard > WPML > String Translation I chose the 'admin_texts_theme_mods_oceanwp' text domain from the dropdown list.

2 - Then, I translated the key '[theme_mods_oceanwp]ocean_footer_widgets_template' with the ID of your translated footer template which is '3002'.

3 - You can see the results at: yourdomain.

See:
https://wpml.org/documentation/getting-started-guide/string-translation/
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Please, let me know if you need any additional assistance and instructions, have a nice day.

August 28, 2019 at 5:20 pm #4476125

sandraG-26

Hello Marcos,
It worked! Thank you!
The margins and layout of the translated pages do not match the original website. Can you please assist me on this matter too?

August 28, 2019 at 5:25 pm #4476135

sandraG-26

Also, I forgot to ask if your Reply #4476121 was private. I see you included the name of the website, which was supposed to keep private.

August 28, 2019 at 8:55 pm #4476867

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. The margin issues happen due an inconsistency in your page settings, specifically the 'ocean_post_layout' in order to keep the same settings for all the translated pages, please, proceed this way:

1 - In your WordPress Dashboard > WPML > Settings > Custom Fields Translation make sure 'ocean_post_layout' is set as 'copy'.

See: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

2 - Now click the top admin language switcher and change to your secondary language and list all your translated pages at WordPress Dashboard > Pages, then click to edit a translated page, click the 'edit anyway' button when prompted regarding the WordPress default page/post editor and just update your pages without making any change.

You can see the results of these actions in your translated homepage. Please, let me know if it works for you, have a nice day.

Note: Although any provide url here is only visible for us the supporters and the customer that opened the forum topic, even so I edited my reply above to delete the previous provide url of your website.

August 28, 2019 at 11:06 pm #4477007

sandraG-26

My issue is resolved now. Thank you!