Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 4 voices.

Last updated by tomazM-2 1 week, 3 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
November 18, 2019 at 2:03 pm #4965721

tomazM-2

I am trying to: show footer in pages in all languages

Link to a page where the issue can be seen:

I expected to see: footer in german and english site

Instead, I got: sites without footer

November 18, 2019 at 3:33 pm #4966385

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello, welcome to the WPML support Forum!

Are these footers generated by the theme or by a plugin? Could you please elaborate a little more on this issue, so we can better understand? E.g. The link of the page, steps you've tried, etc.

Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

November 18, 2019 at 4:54 pm #4966935

tomazM-2

The footer came with Astra starter sites and I edited it in Header footer builder. I translated it to both not default languages. I only have access to my mobile phone right now and can make screenshots later. The default language (slovenian) shows footer as it should be on all pages. The german pages don’t show footer at all. I already found the information on forum about the Builder not being compatible with wpml. So I just added all the content from the footer to the end of home page in english language as just another section made by elementor. It doesn’t work like that on german home page and reports error 500 when adding content from the footer and trying to save the changes.

November 19, 2019 at 7:39 am #4968901

tomazM-2

Here are two screenshots. The first homepage in default language shows the footer. The other homepage in second language doesn't show the footer at all. The footer is translated to all languages.

November 20, 2019 at 2:17 am #4976467

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

November 21, 2019 at 1:04 am #4984845

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. Unfortunately I am still not able to access your WordPress Dashboard due a country restriction, can you please, whitelist my country (Brazil) and give me access for it? Thank you for your collaboration, have a nice day.

November 21, 2019 at 7:53 am #4985689

tomazM-2

I apologize. I didn't see that coming. Can you try now, please?

November 25, 2019 at 7:37 am #5008653

tomazM-2

Can you check please as soon as possible so I can set security settings as they were before?

November 25, 2019 at 12:52 pm #5012119

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Marcos is off for last few days because of sick.
He will get back to you by tomorrow.

Apologies for the delay.

Regards,

November 25, 2019 at 9:44 pm #5017259

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the bit of waiting here, I had to be away for two days due medical restrictions. I took a detailed look in your WordPress Dashboard and noticed some inconsistencies in the footer template settings of your default language and the secondary languages, here are the details on how to solve it:

1 - Click to edit your footer template in your WordPress Dashboard > Appearance > Header Footer Builder settings.

2 - Then change to the secondary languages using the top admin bar language switcher in order to edit the translated footer templates settings, then make sure you have these settings for the 'Elementor Header Footer Options' option (See attached screenshot):

Type of template: 'Before Footer'
Enable Layout for Elementor Canvas Template: checked.

Please, let me know if you need additional assistance and clarifications, have a nice day.

November 28, 2019 at 8:17 am #5033821

tomazM-2

My issue is resolved now. Thank you!