This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Architecturer Theme Elements for Elementor - The footer on translated pages and posts is not showing the translation

Solution:

1. On the 'strings in admin screens section,' I've selected the tg_footer_content_default filed that is the theme_mods_architecturer group. Then I sent it to the String Translation section.

More about the 'strings in admin screens section' at the following link.

https://wpml.org/documentation/getting-started-guide/translating-theme-options/

2. In the String Translation section I could see the [theme_mods_architecturer]tg_footer_content_default string under the admin_texts_theme_mods_architecturer domain. It carries the ID of the German footer. But it was needed to switch the language of the string to German. So I did it by selecting the string and changing its language with the 'Change the language of selected strings' button.

3. Then I inserted the ID of the English footer and saved the translation of the string.

This topic contains 12 replies, has 2 voices.

Last updated by Itamar 3 weeks, 6 days ago.

Assigned support staff: Itamar.

Author Posts
September 22, 2019 at 9:23 am

melitaR

Hello,
I have found how to display footer translation on my site while searching through the support forum, I needed to select my generated footer on every single page from page settings and that worked perfectly. But - my blog posts are still showing the default 1st language footer, and on the single blog posts settings, I have no option of choosing the footer in any of the languages.
Can you help?

My page is under construction, so I am including the credentials here. On my last ticket, there were some login restrictions and the supporter had to use VPN, I hope that's not a problem, as I couldn't switch off the restriction,

thank you!!
best regards,

September 22, 2019 at 9:31 am
September 22, 2019 at 9:38 am #4617981

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

For some reason, you were disconnected from the chat so I've turned this chat into a regular ticket.

Is this where I can see the issue on your site?
Please see the attached screenshot.

Can you please explain to me how did you create the footer that shows on the blog posts?

Also please make sure that it is not a cache issue by clearing all the cache form your site.

Thanks,
Itamar.

September 22, 2019 at 9:59 am #4618011

melitaR

Hi,
& sorry - I had to close my previous ticket on the forum as it was resolved, that is why I left the chat.
Yes, that is the footer area, it is created in the footer section - to be found in the WP selector on the left side (screenshot attached). The footer is translated and working across the site created with pages. only blog posts are showing the problem.
I have a caching plugin installed but it is not configured or activated yet. It hasn't been at all since now. A friend wanted to configure it today, during the day. Can you tell me how I could clean it otherwise?
thank you!

September 22, 2019 at 10:01 am #4618043

melitaR

btw: if the browser cache is meant by what you aresking me I am doing it right now!

September 22, 2019 at 10:05 am #4618049

melitaR

so, the browser cache cleared, no changes. My blog post page is: hidden link
there the footer is correct in English, as soon as you pick one of the blogposts featured there, it shows the German footer, for example:
hidden link

thnx

September 22, 2019 at 5:09 pm #4619075

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the extra details.

I can see the issue on your site.

Is the Footers section being added by the 'Architecturer Theme Elements for Elementor' plugin?

Is so then we need to check if there is some compatibility issue here.

For this, I created a test website with a clean WordPress install. You can access it through this link:
hidden link
Through this link, you will be automatically logged in. (If nobody logs in the test site will be available for one week from today.)
Could you please install the Architecturer Theme Elements for Elementor plugin and see if the issue is replicable on a clean WordPress installation?
Please configures WPML as it is configured on your site.
Please also make sure that you are installing the latest version of the plugin.

Thanks,
Itamar.

September 23, 2019 at 8:36 am #4621653

melitaR

Hi,

thank you for the help.
I assume that the footer is theme related plugin generated element...so,
I have installed the theme, the theme supporting plugin for Elementor, and elementor itself.
i tried to reconstruct my footer and also the WPML settings.
you may kindly take a look in the the Sandbox.

let me know if you need anything else.

best regards

September 23, 2019 at 1:26 pm #4624509

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for setting everything on the sandbox site.

I could also replicate the issue on the sandbox site. However, the issue there is happening not only on posts but everywhere on the site, including pages. Therefore I've escalated this issue to our compatibility team and they will check if there can be a fix for this issue.

I'll keep you updated here for any news regarding this issue.

Thank you for your patience.
Itamar.

September 23, 2019 at 2:26 pm #4624949

melitaR

Hi Itamar,
yes, at first the issue was also occurring everywhere on my site too, but with the help of one support thread, which was already resolved on your forum, I found this solution to go to the WPML settings and in the post-type-translation (see screenshot) my footer was set to "not translatable" which I manually switched to "translatable". That worked across the site only for blog posts not!
It would be absolutely wonderful if your team could come up with the solution!!

thank you!!

September 24, 2019 at 9:47 am #4629833

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Our compatibility team has found the fix for this issue. I've implemented the fix on your site, and now the footer is also in English on the posts' pages. Please see the attached screenshot.

Here is how I've fixed the issue.

1. On the 'strings in admin screens section,' I've selected the tg_footer_content_default filed that is the theme_mods_architecturer group. Please see the attached screenshot tg_footer_content_default.jpg. Then I sent it to the String Translation section.

More about the 'strings in admin screens section' at the following link.
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

2. In the String Translation section I could see the [theme_mods_architecturer]tg_footer_content_default string under the admin_texts_theme_mods_architecturer domain. It carries the ID of the German footer. But it was needed to switch the language of the string to German. So I did it by selecting the string and changing its language with the 'Change the language of selected strings' button. Please see the attached screenshot change-lang-de.jpg

3. Then I inserted the ID of the English footer and saved the translation of the string. Please see the attached screenshot trans-id-en.jpg

Can you please confirm that the issue is solved now and mark this ticket as resolved?

Thanks,
Itamar.

September 24, 2019 at 10:16 am #4630405

melitaR

wow- quite a workaround but I appreciate the effort and all the work.
thank you also for the steps on how you accomplished it, it is fantastic to know for my future work or websites!!!
I will mark the issue as closed.
THANK YOU!!

September 24, 2019 at 10:18 am #4630523

melitaR

My issue is resolved now. Thank you!

September 24, 2019 at 12:16 pm #4631471

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Great, I'm glad that it is solved now!
Good luck with your web projects 🙂
Itamar.