This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Itamar 1 month, 4 weeks ago.

Assigned support staff: Itamar.

Author Posts
July 31, 2019 at 4:53 pm #4316891

andrejJ-3

Tell us what you are trying to do?
I am trying to translate pages but it is not working.
I also tried to translate Domov/Home page, but there is showing just pictures, but without texts.

Is there any documentation that you are following?
Youtube video with classic editor.

Is there a similar example that we can see?
Dont know.

What is the link to your site?
hidden link

August 1, 2019 at 4:44 am #4318691

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,
Thank you for contacting WPML Support. To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

August 6, 2019 at 4:04 pm #4349445

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks but I cannot see login page, when I go to the wp-admin page I see following message:

" Due to protection of web servers from repeated attacks, we were forced to restrict access to administrative interface of web pages to selected countries. If you are currently in a foreign country, please sign in to WebAdmin, proceed to your domain management and disable this GeoIP filter in CMS section. "

Please allow me to access site OR temporary disable country restriction settings. Thanks

August 8, 2019 at 4:02 pm #4364629

andrejJ-3

Hello,

GEO security has been declined.
Thank you for your help in advance.

Best regards,
Andrejko Andy Jahodicka

August 12, 2019 at 4:16 pm #4382257

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Noman is not available today, so I'll continue to handle this ticket. I hope that it is alright with you.

Please make sure that it is not a cache issue by deactivating the W3TC plugin that you are using. Also, please make sure that translations are 100% complete. And, please let me know how you are translating the pages of your site. Sometimes screen-shots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

I've tried to log into your site, but I'm seeing the same message that my colleague Noman saw.
Can you please fix it?

Thanks,
Itamar.

August 12, 2019 at 5:41 pm #4382879

andrejJ-3

Hello Mr Itamar,
GEO IP scurity was declined like last time I informed - you can see also in attachment.
Through the WPML is not possible on our web site change text on Home page, everything else is working.

Thank you.
BR,
Adynko Jahodicka

August 13, 2019 at 9:35 am #4386625

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hello, Adynko Jahodicka.

I'm sorry, but I still can't access your site. And I'm also trying to understand the issue. I think that the issue is that the English version of the homepage is not showing and instead the text is in Slovac the default language of the site.
Can you please confirm that this is the issue?
Please see this video that I've recorded to demonstrate the issue of login and homepage.
hidden link

Also could you please comment about my following questions from the previous reply?
Please make sure that it is not a cache issue by deactivating the W3TC plugin that you are using. Also, please make sure that translations are 100% complete. And, please let me know how you are translating the pages of your site.

Regards,
Itamar.

August 23, 2019 at 11:28 am #4446359

andrejJ-3

Hello Itamar,
I am 100perc sure that GEO IP has been already totaly shutdown.
Could you please check one more time your login?

Thank you.

Your sincerely,
Matus Kromholc

August 25, 2019 at 5:13 pm #4454803

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Matus.

Thanks, I can access your site now.

When I checked things on your site, I could see that you are using a plugin that extends WP Bakery Page Builder. The plugin is called 'ND Shortcodes'. The WP Bakery Page Builder is compatible with WPML. You can see our documentation about how to work with this plugin and WPML here.
https://wpml.org/documentation/translating-your-contents/page-builders/
But the ND Shortcodes is not compatible with WPML. It is not on our list here.
https://wpml.org/documentation/plugins-compatibility/
Luckily, we have a method of adding shortcodes from page builders so WPML's Translation Editor would be able to translate their texts. Please read about at the following link to our documentation.
https://wpml.org/documentation/support/language-configuration-files/
https://wpml.org/documentation/support/wpml-integration-with-page-builders-that-use-shortcodes/
I've implemented one of the shortcodes that you are using. And now it is possible to translate it on WPML's Translation Editor. What I've done is the following.
1. I go to WPML -> Settings -> Custom XML Configuration (tab).
2. Then I add the following code and save.

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>nd_options_text</tag>
            <attributes>
                <attribute>nd_options_text</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Please see the attached screenshot nd_options_text.jpg
3. I go to edit the page (the homepage of your site).
4. I press the update button.
5. I press to edit the English language.
Now I can see that I can translate all the texts from the ND Text element. Please see the attached screenshot trans-slov-to-en.jpg.
Please use this method to add more shortcodes for translation, if needed.

Please note that now you need to finish the English translation of the page to make it show on the front-end.

Please let me know if this information is helpful to you.

Regards,
Itamar.

The topic ‘[Closed] for example home page is not showing to translate’ is closed to new replies.