This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
October 4, 2018 at 8:18 pm #2788711

heatherD-2

Hello,

I'm trying to enable the foreign language connector for my main English site at hidden link

On my DNS server, I have added CNAME records for each foreign site and have each being pointed to the root domain which in this case is predictiveindex.com

CNAME records I added and pointing to predictiveindex.com:
fr.predictiveindex.com
cn.predictiveindex.com
de.predictiveindex.com
kr.predictiveindex.com
es.predictiveindex.com

When I save these settings in the WMPL connector I get an error. A screenshot is attached.

October 7, 2018 at 3:24 pm #2793929

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Please refer to our article 'How to use WPML with different domains per language' at the following link and check that you have done everything correctly.
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Also sometimes the 'Validate on save' option gives a false 'Not valid' message where in practice it works.
Please uncheck the 'Validate on save' option and re-save the settings. Then go to Settings -> Permalinks and re-save the permalinks.
Does it work in this case?

If not, then please tell me how you are setting your server?
Do you do it with a cPanel interface or manually?
Please also make sure that you have not forgotten to add the HTTP server settings.
See the 'Setting up your HTTP server' section.

Regards,
Itamar.

October 8, 2018 at 3:10 pm #2796562

heatherD-2

Hey Itamar,

Within the Language URL Format Section, which option for the Pass Session Arguement should I be using? I set it to disable.

And what am I suppose to be looking for within the Settings -> Permalinks page?

And our website is hosted by WPengine. I do not have access to the server that hosts our main english website. Are these http server settings something I need to have them check and/or do?

Thanks!

October 9, 2018 at 10:36 am #2799489

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

You ask: "Within the Language URL Format Section, which option for the Pass Session Arguement should I be using? I set it to disable."

I usually leave it with the default GET. I do not think that disabling is related to the issue that you are having, but just in case, please set it to GET.
You can read about the difference between POST and GET here.
hidden link

You ask: "And what am I suppose to be looking for within the Settings -> Permalinks page?"

You suppose to press the 'Save Changes' button. Please see the attached screenshot.

And you also ask: "Are these http server settings something I need to have them check and/or do?"

If you have added the subdomains with the cPanel and they are all pointing to hidden link, then you do not need to do anything in the HTTP server settings.

Please let me know if it is working for you.

Regards,
Itamar.

October 9, 2018 at 7:49 pm #2801856

heatherD-2

Hello Itamar,

I followed the instructions above. In terms of the http server setting, I contacted WPengine and they told me everything on their end looks correct. If anything I need to make sure my DNS is set to correctly point the subdomains to the root domain, which they currently are.

Right now when I go to es.predictiveindex.com or any of the other subdomains, it just redirects me to the main english site at hidden link

When the foreign language connector is working, what exactly is suppose to happen? Some goes to es.predictiveindex,com and they get a translated version of the english website?

And is there a log of some sort I can send you to see if you see any issues?

Thanks for all your help!

October 9, 2018 at 8:41 pm #2802074

heatherD-2

And to follow up with another observation i'm seeing, when I hover over the chinese, spanish, etc icon to take me to the translated page, I see the corresponding subdomain as the redirect link. (Chinese points to cn.predictiveindex.com, Spanish points to es.predictivindex.com, etc.) But when I hit either links it redirects me to the english site, which it's suppose to do because that's how I was told to setup the DNS records to do.

Lionbridge does our actual translation for pages and I see that certain pages are translated to the appropriate language but all these translated page aren't being mapped. Are the translated pages not being mapped and/or published correctly? Does something need to be turned on?

October 10, 2018 at 8:13 pm #2805709

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

You ask: "When the foreign language connector is working, what exactly is suppose to happen? Some goes to es.predictiveindex,com and they get a translated version of the english website?"

Yes, they get the translated version if you had inserted any translations. The translation is not being created automatically.

You are using on your site the Redirection plugin (hidden link). Please make sure that there are no redirections set on this plugin that causes the other languages domains to redirect to the main domain.

Please let me know what you have found.

Regards,
Itamar.

October 11, 2018 at 9:22 pm #2809811

heatherD-2

Hey Itamar,

There are no redirects set in the Redirection plugin.

You mentioned "if you had inserted any translation...", not all the pages on my english have translations but some do. Do I need to manually insert, add, or map in the translated pages to the english pages?

October 11, 2018 at 10:32 pm #2809895

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

No, you do not need to manually insert, add, or map in the translated pages to the English pages. It supposes to work. Please try the following procedures.

A. Minimum requirements.
By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

B. Update WPML and add-ons
I can see that WPML and its add-ons are not updated to their latest version on your site.
Could you please update WPML and its add-ons to the latest version?

C. Minimum Environment
I suspect that there might be a collision with the theme or another plugin.
If possible get your site into a minimum environment.
Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated but WPML.
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example).
If it persists, then turn off all plugins but the WPML and its add-ons and WooCommerce itself (leave WPML and its components active).
Then please check if the problem persists.
If it does not persists so start by activating the plugins one by one and check when the problem comes back. Then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Could you please perform those procedures and see if it help to solve the issue?

If none of the above helped to solve the issue, then please share with me the access to your site or send me a copy of your site. You can use the Duplicator plugin for that. https://wordpress.org/plugins/duplicator/

If you need further help with this, please share the access details to your site with me.
I'm enabling private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

P.S. Please note that I'll be able to continue investigating this issue on Sunday.

Thanks,
Itamar.

The topic ‘[Closed] Foreign language WPML connector not working’ is closed to new replies.