Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Gravity forms not translating correctly. How do we link the webpage to the German form.

Solution: Using old WPML version, translations are located WPML>String Translations and you can update them from there.

I advise using the latest version of WPML and Gravity Form addon to make sure everything works correctly.

Relevant Documentation: https://wpml.org/documentation/related-projects/gravity-forms-multilingual/#translating-gravity-forms

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bill Lafferty 1 year, 1 month ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
March 13, 2020 at 10:12 pm #5683495

Bill Lafferty

I am trying to:
Deliver a German translation of a Contact Us webpage. The webpage was sent to us via WPML plugin for en --> de-de translation.

I expected to see:
All text on the page translated into German

Instead, I got:
The Form in the middle of the page is in French.

Questions:
1. The customer uses Gravity forms, and that form was translated into French previously. How do we link the webpage to the German form instead (a German translation was previously produced as well)?
2. On the Translation Jobs page, the xliff associated with the contact us page we translated into German is different than the one we delivered via the plugin. How is this happening? See screenshots.

Private link:
Could you kindly send me a private link? I can provide login credentials to the customer's account.

Thank you!

2020-03-13 18 06 59.png
2020-03-13 17 59 52.png
March 16, 2020 at 3:06 pm #5694429

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Bill,

yes, this isn't expected it should show the German translation of form on the German page.

Can you please confirm with the client that it is oke to share access to his site with us. I would need FTP and WP Admin access.

In the meantime we can go over these steps:

1) In order to expedite handling your support requests, can you please share WPML support debug information

More information on the link: https://wpml.org/faq/provide-debug-information-faster-support/

2) Make sure that they are using Gravity Forms Multilingual. Try updating form content and then sending Gravity forms to translations (both FR and DE) and see what happens.

Documentation: https://wpml.org/documentation/related-projects/gravity-forms-multilingual/#translating-gravity-forms

3) Check what shows in the backend. Go to that form and use language switcher on top to change languages, check what strings are showing.

Since you are a translation service, if you don't have time to test these steps, I will understand no problem. I can do further investigation of the issue once I get access.

Just let me know when you check with the client and I will enable private fields for admin access in your next reply.

Regards,
Drazen

March 16, 2020 at 9:58 pm #5696709

Bill Lafferty

Hi Drazen,

Thanks very much for your reply. I have the debug file to share, as well as the login to their ftp/server. Please kindly share the private link.

The client's web admin confirmed that Gravity Forms Multilingual is enabled (pls see screenshot). Here's what they said:

"In the WordPress code editor for the German version of the page, the form being called has an ID of 10, which is the main Contact Us form and the one that both the English and French versions of the page call as well. However, the English Contact Us page shows English in that rendered form and the French Contact Us page shows French in that rendered form."

Kind regards,
Bill

gravity form multilingual.png
March 17, 2020 at 7:13 am #5698953

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Thanks for the feedback, Bill.

Please make a full backup of your site (files and database) and confirm it in your next reply.

I would need to access your site's wp-admin and FTP account. I have enabled the private username and password fields in your next reply.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

You can safely add your information into these fields. I would also need your permission to access the database as well.

Regards,
Drazen

March 18, 2020 at 8:34 am #5708203

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Bill,

I managed to found the issue. The problem they are using old WPML, back then we didn't have Gravity Forms addon and you would translate your forms using WPML>String Translations.

Now you are trying to translate using WPML and Gravity addon but strings are not shown since there are loaded from String/mo files.

So basically you can update the translations using String Translations, or delete all Translations done in WPML>String Translation for forms and continue to use WPML Translation management for translating forms (update to latest version).

I would advise updating everything to latest version (Wp, theme, plugins) and use recommended WPML Translations procedure, otherwise, you might enter some other issue in the future.

Things I changed:
- Update all WPML plugins
- Generate mo files (popup when you updated WPML)
- Send for translations Contact us 2020

Other steps I did, I reverted back to default after checking.

Please check the attached screenshots.

I hope I was helpful. Don't hesitate to ask if you find any problem along the way, I'll gladly help you.

Regards,
Drazen

Screenshot_8.jpg
Screenshot_7.jpg
Screenshot_6.jpg
Screenshot_5.jpg
March 21, 2020 at 12:53 am #5731043

Bill Lafferty

My issue is resolved now. Thank you!