This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Lauren 5 months, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
April 22, 2019 at 9:30 am

donaldJ

I am trying to: translate French text including non-breaking spaces before certain punctuation items (including ";", ":", "?", "!"). In French, a space before the above punctuation characters is mandator, and it is necessary to make that space non-breaking to avoid the character being on a separate line from the word immediately preceding it. In English typographical usage, however, there is no space between the preceding word and the characters mentioned above. Therefore, when translating, one needs to remove the space.

Link to a page where the issue can be seen: hidden link

The WPML Multilingual CMS highlights all the non-breaking spaces inserted in the French text, and when one tries to remove them, it refuses to allow the translation to be completed. I have found no way around this. Can you help?

Instead, I got:

April 22, 2019 at 7:03 pm #3657971

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Unfortunately, the credentials provided are not allowing me to log in to your site. Can you tell me how you are creating the space in French? Are you using a page builder to create the page content?

Also, when you try to delete it in the translation, are you seeing any errors in your browser console? Here is some information about how to view your browser console: hidden link

April 22, 2019 at 7:09 pm #3658005

donaldJ

The content is being created in two different ways: in Eelementor, and in the normal WordPress interface.

The difficulty is that one doesn't see any errors, just that one can't save the translation if one deletes the non-breaking spaces, because WPML regards them as structuring content.

I recreated the user credentials with the same username and password, by the way, so you can log in now. Sorry, but I had to wipe my staging site owing to another issue since I created them.

April 22, 2019 at 9:29 pm #3658387

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for clarifying. I can see that in the text editor in Elementor, the   is created which is what is causing the problem. Does the translation work if you use the classic WPML editor instead of the Advanced editor? Wondering if that would be an acceptable workaround.

I have escalated this to our 2nd tier team for further debugging, I will keep you posted here in what I find out.

April 23, 2019 at 12:00 am #3658771

donaldJ

I had ruled out even trying to using the classic editor, because I had been given to understand that if I wanted to use WPML's full features with Elementor, I had to use the new editor...

April 23, 2019 at 4:42 pm #3666303

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

You can use the classic editor with Elementor. You are better off using either of the WPML editors, it's manual translation using the native WordPress page editor that can cause problems.

April 23, 2019 at 11:19 pm #3667821

donaldJ

Well, I switched back to the Classic Editor, translated a few very short posts, and then my website became unresponsive, broke, and I had to restore the backup I now systematically create every time I use WPML.

April 24, 2019 at 5:52 pm
April 24, 2019 at 5:52 pm #3675687

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Switching editors should certainly not crash the site. Perhaps there is something more going on. PLease enable the debug log, as that might give me some clue as to why the site crashed.

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

April 27, 2019 at 7:44 am #3694807

donaldJ

The bugs with WPML have become considerably worse since I started trying to follow your advice and use the Classic Translator. As I had expected, the Classic Translator does not translate texts that appear only in Elementor. Now when I need to update a translation, and I try to use the WTA, weird texts with "invalid tag" mentions appear, which are effectively gibberish. I have been wasting so much time unsuccessfully trying to solve these ridiculous issues, that I have now come to the conclusion it will be quicker to completely uninstall WPML and redo all the translations from scratch. Can you please explain how to do a clean uninstall? I have not been able to find this out in the documentation. Thank you.

April 29, 2019 at 1:44 pm #3703949

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The best way to uninstall is to first delete the translated posts/pages/etc from your secondary language. To do this, just click on Posts and then use the admin language switcher at the top of your dashboard to switch languages. Then you can bulk delete the pages/posts. Be sure to permanently remove them from the trash as well.

Once you have deleted the translations, you can then go to WPML -> Support -> Troubleshooting and you will find the option near the bottom to reset WPML. This will remove the tables from the database, and you can install a fresh download.

Please let me know if you need any further assistance and I will be happy to help.