This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by lewisS 3 weeks, 2 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 25, 2019 at 6:38 pm #4641753

lewisS

I am trying to: access pages on the translated French side of the website

Link to a page where the issue can be seen: hidden link (click on any of the menu items)

I expected to see: the page I clicked on

Instead, I got: a 500 error

September 26, 2019 at 2:05 pm #4647415

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before a more detailed look, please, try this basic troubleshooting:

1 - Make sure your server environment meets our minimum requirements as described at: https://wpml.org/home/minimum-requirements/, you can see your current values at your WordPress Dashboard > WPML > Support > Info menu.

2 - Disable all the plugins except the WPML related ones from your WordPress Dashboard > Plugins and see if the issue is gone, if so, activate one plugin at a time untill the culprit one is found.

3 - If the issue persists, temporary change to a default WordPress theme such as the 'TwentySeventeen' theme from your WordPress Dashboard > Appearance > Themes menu.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if the steps above help to fix your issue. Have a nice day.

September 27, 2019 at 1:01 pm #4654273

lewisS

Thanks, Marcos. None of the steps above helped, unfortunately; I'm still facing the same issue. Please advise on next steps.

September 27, 2019 at 3:31 pm #4655609

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

September 27, 2019 at 5:52 pm #4656325

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I checked your error log file and the cause of your issue was not enough server resources to run your website, in your case specifically the memory limit, I increased it to 512MB pasting this line of code 'define( 'WP_MEMORY_LIMIT', '512M' );' in your wp-config.php file and now your issue is gone. In some situations when you run some server intensive plugins, the recommended value of 128MB might not be enough.

See: https://wordpress.org/support/article/editing-wp-config-php/

Please, let me know if you need any additional assistance and clarifications, have a nice day.

September 30, 2019 at 12:45 pm #4664653

lewisS

Thanks for the help, Marcos, very appreciated!