Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Robert 1 year, 4 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 31, 2019 at 3:09 am

Robert

Dear support,

My issue is similar to: https://wpml.org/forums/topic/front-end-admin-bar-not-showing-with-translations/

However the "Auto sign-in and sign-out users from all domains" is switched on.

I have a multisite with .com as the main site
.nl and .cn as languages.
When I create a page in English + Dutch + Chinese the Admin stays logged in when opening English and Dutch page.
However the Chinese page front-end does not stay logged in as admin causing it to show the under construction page instead.

I would like to have the Chinese pages and products front-end stay logged in as admin.

On the dashboard everything works fine.

Also:
I can access domain.nl/wp-admin which redirects to domain.com/wp-admin
I can not access domain.cn/wp-admin (no redirect)

Any thoughts on how .cn can stay logged in as admin on front-end?
I have saved the permalinks

Thank you!

Regards
Rob

May 31, 2019 at 11:36 am #3930207

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum,

Please check whether the xframe header option is disabled in your server,

WPML uses the iframe to share the session among all domains. You need to contact the hosting support to disable an x-frame option for the secondary domain.

You can find out more information here https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Please scroll to the bottom and check

<b>Session expires while switching languages section.</b>

Once it is deactivated please let me know whether it solves your issue.

Please note the login you have provided is not working, I am enabling the private fields again, please share the working login credentials.

Kind regards
Raja

June 3, 2019 at 2:20 am
June 3, 2019 at 12:54 pm #3942377

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Rob,

Can you please remove your custom iframes, You can not access the URL directly by copy-paste you will need our language switcher which sends the request to share the data between domains. So I have placed a footer language switcher to your site. After removing your custom iframe try to access the second language from the language switcher.

I hope this should work. Please let me know the results.

Kind regards
Raja

June 3, 2019 at 1:27 pm #3942745

Robert

Hi Raja,

Thank you for your message.
I've removed the custom iframes. No luck using the language switcher.

Regards
Rob

June 4, 2019 at 6:16 am #3948221

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Rob,

Please disable the timer iframe for a while, While we test the issue, Please clear all the cache.

I think it's better to test the same with a snapshot copy of your site in my local setup, You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/, I have enabled the private fields for you to securely share the details.

Kind regards
Raja

June 5, 2019 at 5:43 am #3957105

Robert

Hi Raja,

Since it was pretty much a fresh install I decided to run a new installation, without creating a multisite. Since it's one installation it looks like I don't need multisite settings for what I want to do.

After fresh install it switches admin just fine. yay!

Sometimes doing a fresh install is the quickest solution...

Thanks again for your patience.

Regards
Rob