We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 12 replies, has 2 voices.

Last updated by Bobby 3 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 25, 2019 at 9:43 am

daneelM

Hello!

I am translating a site built with Oxygen Builder.

Translating the text is ok.

Firstly: Pages -> Home -> Add translation to Russian.

Everything worked and displayed fine, however the button text is not picked up.

So my process: Pages -> Russian -> Home -> Edit with Oxygen.

Within Oxygen I simply change the button text to Russian and save.

Now the front end looks like screenshot attached. I have also attached its original.

I realise that there are known issues between O2 and WPML. To me it seems like saving it has messed with the formatting of the elements. Because it's not simply the images that are not showing up but all the styling is lost too. Also I have not used any media translation as I currently do not require it.

Any idea where the issue could lie? It is set up on a staged site so happy for you to have a look and do what you need to do if required.

Thanks.

June 25, 2019 at 9:09 pm #4087259

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

Thank you for providing the staging site

are you currently using Oxygen Re-Usable elements and Templates ?

if so please review the following documentation and let me know your results after trying the workaround provided

-> https://wpml.org/documentation/plugins-compatibility/oxygen-visual-builder/#translating-oxygen-reusable-elements-templates

also here you can find a user provided solution that could be helpful
-> https://wpml.org/forums/topic/oxygen-builder-and-template-compatibility/#post-2993410

June 28, 2019 at 3:39 pm #4109075

daneelM

Hello!

Sorry for the late response.

I have read both of the links you have sent me previously. I understand that the work around for the templates and the duplication. I am currently not using any re-usable elements either.

The issue is that once a page or a template is translated, the formatting on the front end is messed up. (see image of back-end vs front end for both the home page and an example "destination.")

Additionally, despite saying that templates are not translatable, the option appears in the WPML "post types translation" (see templatesTranslate screenshot). When attempting to "translate a template" everything works fine with regards to text. However it does not seem to carry over the styling. (refer to front end vs back end)

Should I not use this feature at all and simply duplicate as mentioned in the instructions?

The templates also seem to appear the as translated the same way that posts and pages do (see templatesTranslated screenshot)

It seems like this feature is almost ready to work perfectly despite the instructions saying it is not possible. But maybe I have understood incorrectly.

Another point I am a little stuck with is that the ct_templates come up as "translatable" within the "custom fields translation" option (see ct_templates screenshot) I assumed that this may be where the issue may lie - so I decided to use the copy / copy once feature in order to carry any of the template styling over. But it did not seem to have any effect. Maybe you can suggest what to do with this?

Again, feel completely free to play around with the staging site I have created in order to test this. No worries about breaking anything and feel free to use the automatic translation where required (I will need to get extra credits either way).

Please don't hesitate if you need any more information. Hope it all makes sense.

Thanks!

June 29, 2019 at 12:19 am #4110335

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

At the moment the template translation will cause issues and it is best to use the workaround

"Should I not use this feature at all and simply duplicate as mentioned in the instructions?"

i'd say yes, that the following steps from the documentation are the best way to go about translating the templates. Our Compatibility team is in contact with Oxygen's Developers but at the moment the translation is not possible for the templates.

Duplicate the default language template using a plugin such as Duplicate Page.
Go to the editing screen of the template that you duplicated and edit it using the Oxygen builder.
Add the translated text to the template and click Save.
Translate the default language page.
On the default language page editing screen, use the language switcher in the Top Admin bar to navigate to the secondary language editing screen.
Choose the template that you translated in step (2).
Click to Update the page.

what are your results when follow the steps for the workaround ?

As we are going to use the workaround the custom field option should not cause any issues here and most likely not going to play a role as we are not translating the templates with the traditional way.

NOTE : if the workaround steps are not clear please let me know and i can help you with how to proceed. I have test this on my local environment and it works as expected

July 2, 2019 at 11:47 am #4126427

daneelM

Hello.

So I reset the stage back to its original setup (i.e. prior to translations)

I am starting with just the home page.

I duplicated the "main" template and translated the text by hand.

I then translated the home page using wpml and manually set its template to "main-ru."

Everything works as expected (see frontb4buttons) but the buttons are not translated.

So I go to edit page with oxygen, just change the text of the buttons (the same way I did for the template) and click save. (see backAfterButtons)

Then the front page is again messed up in the same way it was before (see frontAfterButtons). It seems like it is the saving of a change on a translated page that is causing an issue. Maybe it is from the Oxygen side?

Also, with regards to the duplicating of templates.

I have 300+ "cruises" in custom post types. I am worried that if I have to chose the template by hand it will take an extortionate amount of time. Additionally new ones get added regularly, so having to do it manually is something I would like to avoid.

Previously when I set the templates to translatable, it would automatically detect the template change too. So, for example, the "destination" custom post when translated would also automatically change the template used to the "translated template." Which is ideal!

For me, the translation of templates has seemed totally ok and worked. The only issue I have been having is the styling of both pages and templates is lost somewhere (even when using the work-around) when attempting to "save" something from within the oxygen builder on a translated page / post / template.

July 2, 2019 at 11:25 pm #4130429

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

At the moment the workaround is the expected way to translate the templates using Oxygen this is something that our developers are aware and have done various tests but at the momen oxygens templates are not supported by WPML.

I did however "clone" the home page and then was able to view the correct layout in the secondary language as expected. Additionally i made a change to one of the image titles/button and the layout remains as expected (feel free to delete this , i created so i could make the change without affecting your default page.)

hidden link

July 3, 2019 at 10:30 am #4134921

daneelM

Hello.

Ok no worries.

Thanks, what is it you did differently in that case? Why did it display correctly for you and not for me?

When you cloned and translated it did the buttons translate along with it or did you have to change the buttons through oxygen?

Thanks.

July 3, 2019 at 5:31 pm #4138411

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

the buttons were translated already and to try to replicate it i went through the oxygen builder and changed a button and saved but the layout did not break therefore i wasnt able to replicate the behavior.

if there is a specific step i can follow to further test please let me know so i can try to reproduce it again

July 5, 2019 at 2:09 pm #4151927

daneelM

Hello.

WPML is seeming to be an absolute nightmare! I tried to recreate your steps and kept getting the same issue. No buttons translated, when I change something in oxygen it breaks the styling.

I decided to start again, completely from scratch.

I followed the steps here (https://wpml.org/forums/topic/delete-and-restart-wpml-plugin-setup/)

When attempting to re-install WPML I got the exact same problem I had before. See my previous thread (https://wpml.org/forums/topic/error-activating-wpml-multilingual-cms/#post-4030653) but got around it.

I tried simply translating the home page again, and the exact same issue. No buttons translated, and when changing a single button text I get the exact same styling as before.

Please see the screencast to show my whole process:

hidden link

Excuse the "shortcode signing part" halfway. I have to do this in order for it to display.

What is it that I am missing or doing wrong?

Thanks.

July 8, 2019 at 6:22 am #4159289

daneelM

Hello.

I am still awaiting a response regarding this.

Thanks.

July 8, 2019 at 7:05 pm #4165223

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

i was able to reproduce the issue on a staging environment so i could further test it without interfering with your live site.

i have recorded a screencast of the issue and of the solution.

in my screencast you will see me translating the homepage using 2 different methods

1. WPML classic Translation Editor (side to side)
2. WPML Advanced Translation Editor

With #1 i do the following process (This works):

1. Add translation
2. Go to pages->Edit home page->use language switcher at the top to switch to secondary language and set the template from Main(Default) to "Main RU" and update the page.
3. Click to edit with Oxygen and change the translations of the buttons and save
4. visit the front end and it works as expected

With #2 (This does not work breaks the front end) :
0.5 : Go to WPML->Settings->Switch to use the Advanced Translation Editor
1. Add translation
2. Go to pages->Edit home page->use language switcher at the top to switch to secondary language and set the template from Main(Default) to "Main RU" and update the page.
3. Click to edit with Oxygen and change the translations of the buttons and save
4. visit the front end and it is broken now

please review the following screencast and test the translation using the classic WPML Translation Editor , also please make sure you add the duplicated template instead of using the default language template

hidden link

July 15, 2019 at 10:20 am #4209647

daneelM

Hello.

Sorry for the late response.

I tried using the classic editor instead, however, on my side the same issue still persists.

July 16, 2019 at 6:27 am #4216533

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

i went to your site and followed my steps as shown in the above screencast and was able to translate the button without breaking the template.

screencast of me working on your site
-> hidden link

1. Go to WPML->Settings->Switch to WPML Classic Translation Editor (Important)
2. Go to pages-> add the translation using the Translation Editor
3. Go to pages->Edit default language->use top language switcher and switch to Russian version -> change the template to the new "cloned" template (important, you have to use this workaround for templates)
4. Edit with Oxygen and change the buttons and save