Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by carmenD-4 2 years, 11 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
February 13, 2019 at 3:28 pm #3194948

carmenD-4

What are you trying to translate? I have a Slider on the Frontpage in the Hawea Theme. 5 Sliders with Image, Text and Link. I have two languages, german and spanish. For every language I want a different link and text. I tried de string translation like many instructions I found on the forum. But when I apply the Strings, they don't appear to get translated. What I'm I doing wrong?

What are you seeing? (please include a screenshot)

What's missing or not working for you? I can't "create" two sliders for frontpage, one with german links and text, one with spanish.
The site is not live yet.

February 13, 2019 at 5:47 pm #3195699

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I was not able to find the theme you are using in our official WPML-compatible themes directory here: https://wpml.org/documentation/theme-compatibility/

I also looked at this link here (hidden link) and at point 9 (Theme Translations), I was not able to find them saying anything about WPML so the theme might not be compatible with WPML after all, but I would like to also take a look over your site first.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai Apetrei

February 14, 2019 at 10:22 am #3198772

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

From what I can see, the strings are added for translation inside WPML > String Translation.

Can you please go here (hidden link) and look on the column called "Name" for:

- [theme_mods_hawea]hawea_slidefive_text (from "_slideone" to "_slidefive")
- [theme_mods_hawea]hawea_slidefive_link (from "_slideone" to "_slidefive")
- [theme_mods_hawea]hawea_slidefive_img (from "_slideone" to "_slidefive")

Just translate each of the strings, check the "Übersetzung ist abgeschlossen" box and hit "Speichern" button.

Let me know if that works. 🙂

Kind regards,
Mihai

February 14, 2019 at 11:33 am #3199130

carmenD-4

Thank you a lot! That worked perfectly!
Can you just also help me with the shop menu on the right? I can't find the string to translate Account and Cart to german and spanish.

February 14, 2019 at 12:03 pm #3199410

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

I am very happy to hear that this worked!

In our forum, we try to keep one issue per ticket.


Continuing with one ticket per issue helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.

As the original issue is resolved may I kindly ask you to please mark this ticket as resolved and open a new ticket for the additional issue?

Also, in the process that you have to follow to create a new ticket, you can even choose me to take care of your ticket if you prefer that. 🙂

I would be more than happy to help you with that, too.

Kind regards,

Mihai

February 14, 2019 at 4:39 pm #3200968

carmenD-4

My issue is resolved now. Thank you!