This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Jamal 3 months, 2 weeks ago.

Assigned support staff: Jamal.

Author Posts
June 24, 2019 at 11:03 am #4076813

T4ng

I created an Elementor section in US English.

Then, I translated it to French through the classic translation editor (which I usually never ever use, but for these sections, if I don't, my template will be broken?! Whatever...), then from the french admin views, started a translation to General English, expecting the translation being done from the american (much more convenient for an english to english translation). Then no... The translation is offered from french, even though that's not the native language.

Now I just can't properly cancel this translation. I can cancel, resign, from the classic editor, or the translation management panel... Anytime I'll try to do this translation, it won't forget the mistake I did before.

June 24, 2019 at 5:07 pm #4078895

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

Please add a screenshot of the Elementor section and allow me temporary access to check this further. Also, please make a database backup to recover the current situation if needed.

Best regards,
Jamal
WPML Support

July 2, 2019 at 9:19 am #4125301

T4ng

Same problem from our preprod, where you can test it. How can I send you the details privatly?

July 2, 2019 at 1:43 pm #4127493

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I activated the private box to share credentials safely.

Best regards,
Jamal

July 3, 2019 at 9:53 am #4134281

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for the credentials. I made the reply private to not disclose the data on it.

See the attached screenshot. I canceled the job that is still in progress. The first one cannot be canceled or delete as it is already completed.

I hope this answers your request. Let me know if there is anything else I can do for you.

Best regards,
Jamal

July 3, 2019 at 10:16 am #4134557

T4ng

Ok, then try to translate it again from the US page listing, and you'll see the classic translation editor will still offer to translate from french. Therefore, I have no way to get the english content for translation basis. Which really is a pain in case I have to translate a page with extensive content.

July 3, 2019 at 3:18 pm #4137845

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

I tried the following and I canceled the translation job each time.
- Create International translation from pages list. CTE show French->International.
- Send the page to translation from Translation Management. CTE show French->International.
- Unlinked the French translation then link it again as a translation of the English page. Then send a translation job through Translation Management. CTE show French->International.

I think there was a workflow error when creating these two pages. Maybe a duplication from another page, or that the French page was created separately then linked to the English one, and the source language was set as French.

I would like to know if this issue is only happening for this page or is it happening for multiple pages?
Does the website always had US as default language or was it changed to US?

Best regards,
Jamal

July 4, 2019 at 7:52 am #4140875

T4ng

Hi,

I don't think I did anything special with that one.
For this example, I just created the post from US English, then translated it to French (with the +, to get the CTE), then switched to french admin view, and created the International English version).
It's a preprod, you can try creating a new post and see what happens.

I don't think either we changed the original language either since the beginning.

July 5, 2019 at 8:45 am #4149263

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

My apologies for the late reply. I run a test on a new page.
hidden link
1. Translate to French=> OK.
2. Translate to Internation => OK.
3. Translate to German => OK.

I suggest that you remove the original page and its translation, then remove them permanently from the trash. Then recreate the original page and proceed to translation.

I'll remain at your disposal.

Best regards,
Jamal

July 5, 2019 at 1:13 pm #4151515

T4ng

Hello,

Thanks for that, but you'll admin that's quite a process... That means I have to rework my whole page from scratch. Or copy it, delete the previous one, remove it from trash, then get back to work on the copy, rename it, translate, etc... Why deleting a translation from trash doesn't basically reset it?

July 5, 2019 at 2:59 pm #4152275

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I admit it may be a long process. But if this issue is happening for only one reason, I believe it will be a fast way to resolve it.
But remember, that you will need to create the new page from scratch. If you duplicate or copy using a plugin, maybe other information will be duplicated/copied and cause the issue again.

Why deleting a translation from trash doesn't basically reset it? Because we still keep a link in some WPML tables about the links. Until the link is rewritten again, we still keep a trace of the old one. And if it is still in the trash, this may lead to errors.

Best regards,
Jamal

The topic ‘[Closed] Fully drop translation job’ is closed to new replies.