This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by elsW 1 month, 2 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 7, 2020 at 11:23 am #5856593

elsW

hidden link

All the media-files seem to be copied (after sync?), but I only need one copy of each file, because the galleries and pictures are the same on English and Spanish site. I don't know how to do a rollback.

Pagination is not visible on translated projectpages.

The layout (line height) on translated site is different on some modules of the projectpages, but I cannot open the advanced translation editor (which I originally used to translate.)

I solved all other issues with the forum and documentation, these are the last few things and I hope you can help me, but I cannot find the solutions for this ones.

BTW I am using DIVI Visual page builder.

April 8, 2020 at 5:19 pm #5868461

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. The media duplication process in WPML doesn't actually duplicate the media files, instead it only adds additional entries in the database for media items information such as titles, attributes and so on. See: https://wpml.org/documentation/getting-started-guide/media-translation/#media-translation-settings.

As regarding your missing gallery in the secondary language, please, try the following:

1 - Click to edit the page/post where the gallery is missing in the default language, then make a minor editing for it.

2 - Now, click to edit the translation for this page/post and just resave it. The purpose here is just to refresh the translation and make sure the settings of the default language page/post are copied to the secondary language.

Please, let me know if it helps, have a nice day.

April 9, 2020 at 8:32 am #5873375

elsW

Hello Marcos. Thanks for your answer, but unfortunately it didn't solve the problem I changed something in the default language, but then: when I open the project page in the second language in the advanced translation editor all the translations seems to have disappeared! The translations I did before are now shown in the default language again.
So I didn't save the project page, I left the page to prevent overwriting the translations I already did.

I'll enclose some images to show you what happened.

April 9, 2020 at 10:10 pm #5879683

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Note: Due a national holiday (Good Friday see: hidden link I will be only available on the next monday, if you have urgent needs to fix your issue, please, let me know and I will forward it to one of the available support agent.

Please, let me know if you need any additional details. Have a nice day.

April 10, 2020 at 3:55 pm #5885025

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi - my colleague is not available at this time but I will jump in and help you 🙂

Thank you for your amazing patience and thank you for sharing the credentials.

I was able to log into the backend of the site and I realized that the media was not translated so I went to WPML > Settings > "Media Translation" section and translated the media files.

Now, the images from the gallery are correctly loading inside the translated version (hidden link) and you can see that the pagination shows up correctly, too.

Related documentation (in case you want to take a look):
https://wpml.org/documentation/getting-started-guide/media-translation/

I wish you an amazing weekend and I hope that I was able to put a smile on your face 🙂

Kind regards and please stay safe,
Mihai Apetrei

April 11, 2020 at 1:03 pm #5888775

elsW

Dear Mihai,

Thanks a lot and yes I am a little bit happier now :-).
However after checking the site (Spanish version) there are still issues to be solved and the interface of WPML is not so intuitive to easily find the solution.

And some things are not normal behavior for sure! So I hope you are willing to take another look and help me out on the next things:

In the Spanish version I now find two times Beach house Málaga (one with WPML behind the name), the (in the dashboard second) projectpage of the small apartment has disappeared in the Spanish version. (see enclosed picture).

The projectpage 'facelift small apartment' opens in the basic translation editor and not in the advanced editor

The pagination in the English version is perfect (this was working before as well), pagination in Spanish version is still not visible. I'll enclose a picture.

When I transfer to the Spanish language, the custom links go to the correct section of the homepage. However when I am on a projectpage and then click an item in the singlepagemenu on top, user is redirected to English version on top of the homepage. User should be redirected to the right section on the homepage in the chosen language!

These are not things I can solve with following documentation, so I hope you can help me out with this!

Thanks a lot!
Els

April 13, 2020 at 12:00 pm #5896015

elsW

Dear Mihai,

I solved the thing with the projectpages by making them a new, translate them and delete the old ones.

Problem with custom links in the menu and pagination is still not solved. Hope you can help me with this when you are back in office.

Have a good Easter.

Els

April 13, 2020 at 5:27 pm #5898187

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Els and welcome back.

I'm glad that we were able to fix a few things.

I think you were still seeing my "WPML" test project because it was not removed from the Spanish trash in the backend, I removed it now.

The galleries and pagination look correct for me now.

Also, regarding the other navigation issue that you mentioned where for example in English "facelift small apartment" was showing at the bottom of the page under the "how it was before" section while in the Spanish translation, there was no navigation at the bottom to go backward or forward, I found out that this was caused by the fact that in the default-language page (hidden link) on the right side, "Project navigation" was set to "Show" while in the translation page (hidden link - click "Edit anyway" when the dialog box opens), on the right side, "Project navigation" was set to "Hide".

You will need to make this changes for each of the projects individually (default content edit page + translation page) - practically, go to Projects (make sure Spanish is selected at the top), click "Edit" on each of them, click "edit anyway" and on the right, make sure "Project Navigation" is set to "Show" then save.

From my understanding, there are a couple of new things that you need help with.

Our support policy allows us to take care of only one issue per ticket.


Continuing with one issue per ticket helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.

As the original issue is resolved may I kindly ask you to please mark this ticket as resolved and open a new ticket for the additional issue?

Thank you very much for your understanding and we are looking forward to helping you with the other issues in the upcoming tickets.

Kind regards,

Mihai Apetrei

April 13, 2020 at 5:39 pm #5898395

elsW

Hello Mihai, Yes about the pagination! I remember and I'll fix that and make another ticket for the menu. The projectpages look fine now in both languages.
Thanks for your help! have a good day.

Els

My issue is resolved now. Thank you!