This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.17 hours from now. Thank you for your understanding.

This topic contains 8 replies, has 3 voices.

Last updated by sarah.n 6 years, 3 months ago.

Assigned support staff: sarah.n.

Author Posts
July 21, 2013 at 7:15 pm #147027

Antonio

Hello,

I'm in a really bad place at the moment, I have four days to publish this website and I cannot manage to make the standard wp gallery work in the translations.
I'm using the latest version of WP and WPML
The host is WPEngine

I've already tried with the media translation add-on but with that one there are way more problems, all the images disappear from the media gallery.

If I duplicate the pages the gallery does not show.
If I create a brand new page and upload new medias it doesn't work at all.
The gallery simply remains empty. In the default language there are no problems at all.

Please help

Kindest Regards,

Antonio

July 21, 2013 at 10:56 pm #147040

Antonio

Anyone?
I've seen some post published after this one had a reply...

July 22, 2013 at 5:17 am #147059

Amir
Supporter

Antonio, we will make sure that this is resolved for you. Please help us by showing exactly what you are doing, what you are seeing and where things go wrong.

You can upload screenshots to this thread. Please include:
1. Screenshots of the WP admin, showing the uploaded media for the original content
2. Screenshots of the WP admin of the media menu for the translated content
3. Explain what you are inserting into the content
4. Show what you are seeing on the front-end

Please remember that WordPress will display in the 'galleries' only attachments that belong to that specific post. If you are manually inserting images that are already attached to a post in a different language, they should not appear for the translated content.

The WPML Media Translation plugin addresses this issue. It duplicates the 'attachment' items for the translated content. This way, the same image can appear in the 'gallery' of different languages.

I understand that you have the Media Translation plugin disabled right now. This means that this functionality is not running, so not having the images in galleries in multiple languages is expected. It should work once you receive a new version of the media translation plugin and can run it in your site, together with the latest version of WPML, which will be 2.9.1.

At this time, we want to make sure that we are talking about the exact same thing and that we are not overlooking anything else. If you can provide these screenshots, we'll be sure that nothing else is hiding and you get a solution for your problem on time.

Our developers and support people are in Europe. It's almost morning now and they are just starting their work week (Monday). We will do our best to support you, fix these issues and get your site on time to your client. We just need to know exactly what's happening. Thanks.

July 22, 2013 at 5:45 am #147063

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Antonio,

In this comment: http://wpml.org/forums/topic/media-files-disappear-from-my-media-library-andor-do-not-duplicate-correctly/#post-147051 you wrote
"if I click on edit gallery the media uploader is empty and on the front-end there are no images. The Default Language works the translations have this problem."

Please go under "WPML -> Support -> Troubleshooting" and from within "WPML settings" search for [custom_posts_sync_option]

Can you please copy and paste what you have inside that array?

Thank you.

July 22, 2013 at 5:50 am #147065

Antonio

Hi Amir,

Thank you very much for your reply.
I understand that without the media plugin the galleries have problems but it was the exact same with the media plugin with the addition that the media library was completely a mess.

WP Version: 3.5.2
WPML Version: 2.9
String Translation Version: 1.8

Process:

Create page in default language, upload all media and insert text.
Click duplicate -> Update
Switch to translated language, translate the content and do the required changes.
Update the page.

July 22, 2013 at 5:53 am #147073

Antonio

Hi Sarah,

Thank you for your help, please find the array below.

[custom_posts_sync_option] => Array
(
[merchant] => 1
[attachment] => 1
)

July 22, 2013 at 5:59 am #147077

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Antonio,

Thank you for getting back to me.

Now this is what I would like you to do.

1. Go to your Media Library and locate an image file. Click on "Edit" to go to the "Edit Media" screen of this file.

2. Scroll all the way to the bottom of the page and look for the "Make 'Media' translatable" checkbox.

3. It should be disabled. If it is already disabled, enable it first then save. Next disable it and save again. This will cause WPML to re-save its settings.

4. Visit the "WPML settings" ("WPML -> Support -> Troubleshooting") again and search for [custom_posts_sync_option] you'll see that [attachment] is on 0 as it should be*.

* It should be either on 0 or not there at all!

Let me know whether the above fixes the problem.

July 22, 2013 at 6:10 am #147083

Antonio

Hi Sarah,

Thank you very much for your help, It worked like a charm. You literally saved my company from a giant legal action.
Do you have any Idea on why the settings was incorrect?

Now in order to translate it I will have to use the media translation plugin?

July 22, 2013 at 6:34 am #147088

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Antonio,

So glad to hear this was an easy fix!

You asked: "Do you have any Idea on why the settings was incorrect?"
Well, not exactly sure but yes I have a suspicion on how this happens. There is no need for concern though as with the upcoming WPML Media update this should not happen again.

You also asked: "Now in order to translate it I will have to use the media translation plugin?"

The process you described in your previous comment:

Create page in default language, upload all media and insert text.
Click duplicate -> Update
Switch to translated language, translate the content and do the required changes.
Update the page.

Is correct only remember when you save/update the default language post/page make sure that the following two settings:

"Duplicate uploaded media to translations"
"Duplicate featured image to translations"

Are enabled.

For further information please see: http://wpml.org/documentation/getting-started-guide/media-translation/

Hope this helps.

The topic ‘[Closed] Galleries do not display in translations’ is closed to new replies.