Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Tia 4 years, 7 months ago.

Assigned support staff: Tia.

Author Posts
February 3, 2016 at 4:09 pm #803957

Tia

Renzo, I was unable to pinpoint the issue but I have narrowed it down. The issue lays in:

- madrid/library/includes/shortcodes/shortcodes.php, function code125_columns_grid around line 1581. I believe it's the way categories are being called.

- I have added $args['suppress_filters'] = 'false'; and 'suppress_filters' =>'false' which allows WPML to filter languages.

- I also noticed deleting 'category'=>'', from the $atts around line 1586 makes all posts show up. Close!

I hope that helps.

I suggest trying the shortcode solution first as suggested earlier in the thread.

You can also consider contacting one of our certified partners from this link:
http://wpml.org/documentation/support/wpml-contractors/

They should be able to assist why this isn't pulling correctly.

Before doing so please have a look also here:
http://wpml.org/documentation/support/wpml-contractors/guidelines-for-people-looking-for-consulting-help/

February 4, 2016 at 11:54 am #804814

Renzo

"- I also noticed deleting 'category'=>'', from the $atts around line 1586 makes all posts show up. Close!"
> If I delete this line in the program it is as if will not filter the categories. In this case it also works without deleting this program line. But that's not what I need.

"- I have added $args['suppress_filters'] = 'false'; and 'suppress_filters' =>'false' which allows WPML to filter languages."
> At what point you entered this line of programming? At what line?
> What makes this program line?

February 4, 2016 at 11:35 pm #805416

Tia

suppress_filters allows WPML to apply language rules in order for the correct languages to show. This could still be the issue in addition to the category issue but it's hard to tell.

(sorry, I ended up omitting $args['suppress_filters'] = 'false';)

Added around these lines:

'suppress_filters' =>'false', (line 1609)

Context:

$atts = shortcode_atts(
	array('type' => 'portfolio',
		  'offset' => 0,
		  'paging' => 'true',
		  'child_cats' => 'true',
		  'show_count' => 'true',
		  'height' => 'fixed',
		  'shape' => 'square',
		  'link_type' => 'link',
		  'animated' => 'true',
		  'col_count' => '4',
		  'orderby'=> 'date',
          'meta_key' => '', 
		  'order'=>'DESC',   
		  'category'=>'',
		 
		  /* 
		  'category'=>'',
		  'cat_post'=>'',
		  'cat_portfolio'=>'',
		  'cat_team'=>'',
		  */
		                                 
		  'suppress_filters' =>'false',
		  'filter'=>'true',
		  'posts_per_page' =>'8' ), $atts);

'suppress_filters' => 'false', (line 1671)

Context:

	if($atts['category']==''){
		$args = array(
		'posts_per_page' => $atts['posts_per_page'], /* you can change this to show more */
		'post_type' => array( $atts['type'] ),
		'offset' => 0,
		'paged' => $paged,
		'order'=>$atts['order'],
		'orderby' => $atts['orderby'],
		'suppress_filters' => 'false',
		);

'suppress_filters' => 'false', (line 1681)

Context:

	}else {
		$args = array(
		'posts_per_page' => $atts['posts_per_page'], /* you can change this to show more */
		'post_type' => array( $atts['type'] ),
		'offset' => 0,
		'paged' => $paged,
		'order'=>$atts['order'],
		'orderby' => $atts['orderby'],
		'suppress_filters' => 'false',
		'tax_query' => array(
February 5, 2016 at 2:53 pm #806000

Renzo

I made the changes as you've indicated, but does not work.
I thought you talked to those of Code125 for help, because you are WPML!

The theme is no longer on Themeforest and I think Code125 can not give me more support.
It is not very professional to sell a theme that should work with WPML, and if it does not work, do not give more help.
I think I'll have to redo the new site using a more serious theme ... sob!

Thanks anyway for trying! 🙂

February 6, 2016 at 1:00 am #806356

Tia

As explained prior: https://wpml.org/forums/topic/gallery-doesnt-show-a-category-of-portfolio-choice/#post-800324, I was looking for a quick workaround and hoping to get you closer toward a resolution as we normally do not do this kind of work with other products.

We can attempt to contact Code125 but if the theme is no longer supported or being sold it is unlikely they will work with us. Additionally, this step usually takes awhile.

I highly recommend trying the shortcode route as suggestion before, at least for now so you do not have to redo anything.