This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by sadafJ 1 month, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 20, 2019 at 8:14 pm #4426303

sadafJ

I am trying to fix galley .
Link to a page where the issue can be seen is hidden link
I expected to see is hidden link
MY Galley isn't show any picture on translated page. My original page is English page that I sent you the link above.

I would be very grateful if you could provide me with any information.
Best regards
Sadaf

August 21, 2019 at 11:37 am #4430853

sadafJ

Dear Sir
I have received an email about this issue. They suggest me to add other language LTR.
I added a German language. I see that my problem still remain. Pictures in galley doesn't appear.
It is german translated page <hidden link;
It is Farsi translated page hidden link
and my original page is < hidden link >
Gallery doesn't show any picture when I translate a "Gallery Web page".
I look forward to hearing from you.

Best regards
Sadaf

August 21, 2019 at 2:18 pm #4432211

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 22, 2019 at 5:14 pm #4441795

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and could notice the issue. Please, try the following:

1 - In your WordPress Dashboard > WPML > Settings > Media Translation make sure the ' Translate existing media in all languages', ' Duplicate existing media for translated content', 'Duplicate the featured images for translated content' are checked and the click the blue 'start' button, wait for the whole process and try your translated category again.

I noticed your media library in your secondary languages are empty in your WordPress Dashboard > Media > Library and it could be the cause of your issue here.

Please, let me know the results. Have a nice day.

August 26, 2019 at 1:23 pm #4459173

sadafJ

My issue is resolved now. Thank you!