This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Bruno Kos 2 months ago.

Assigned support staff: Bruno Kos.

Author Posts
March 24, 2020 at 11:05 am #5750137

alessandraV-3

Tell us what you are trying to do?
I am trying to send all items to translation, so I can use memoQ. The number of items in the basket is ca 2300. Yet, I get a timeout error.

Gateway Timeout
The gateway did not receive a timely response from the upstream server or application.

Is there any documentation that you are following?
https://wpml.org/translation-service/memoq/#sending-content

But I do not have memoq server, only memoq for freelancers.

What is the link to your site?

March 24, 2020 at 1:15 pm #5751295

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

I talked to my colleagues about this and sending so many jobs at once will not work unfortunately, so we will have to go in smaller batches, like 50 or so, maximum that can go through translation proxy.

There have been talks about implementing the solution that would allow much larger amount of jobs being sent at once, but this is a very complex thing and will not be implemented anytime soon.

You could perhaps try something in these lines, but I'm not sure if it would help:
https://wpml.org/forums/topic/i-want-to-export-all-our-products-to-send-to-a-external-translator/#post-5411283

Regards,
Bruno Kos

March 25, 2020 at 7:13 am #5757469

alessandraV-3

Thank you for your fast answer.

I have full admin access to the site but I am not sure what time out I need to increase (and how).

On the other hand, I wonder if there is a way I can create the files in batches and then download them in via ftp.

March 25, 2020 at 7:27 am #5757533

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

These directives:

max_execution_time = 360000
max_input_time = 6000

Are server-side, even though they can be changed via php.ini file in your site root.

However, this will most likely not make any difference, as translation proxy will not be able to accept as many jobs at once. So you can either:
- send them in batches of 40-50 or maximum it can be handled, based on the amount of content
- do it like this: https://wpml.org/documentation/translating-your-contents/using-desktop-cat-tools/configuring-xliff-file-options/

Regards,
Bruno Kos

March 25, 2020 at 7:29 am #5757535

alessandraV-3

Also, all the files are in the translation basket now and cannot go back to the 50 files per batch as you recommended. I need help. Thanks.

March 25, 2020 at 7:33 am #5757541

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

You can clear the basket and start sending it in smaller batches. There is nothing else I can recommend, really, as nothing else will work.

Regards,
Bruno Kos

March 25, 2020 at 9:24 am #5758489

alessandraV-3

Hi again,
I managed to make it work but I've been doing it for 4 hours and I'm still beginning now to export jobs (I have to go page by page and as soon as the jobs of 1 page have been exported it goes back to page 1. There are 106 pages of files).

You really have to improve the workflow for such circumstances. Can you ask WPML to improve this? At least being able to indicate the page of files I want to open in the Translations section.

Right now this is really unsatisfactory.

March 25, 2020 at 9:52 am #5758747

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Does it help if I tell you that you can switch the number of translations showing on the screen options, to something like 100 and export then?

Regards,
Bruno Kos

March 25, 2020 at 10:12 am #5759013

alessandraV-3

Yes, it helps indeed.

Yet, what about importing files back? I cannot import 4,600 files (two languages) one by one.

March 25, 2020 at 10:18 am #5759121

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

You can put jobs in one zip file and upload them like this.

Regards,
Bruno Kos

March 30, 2020 at 9:44 am #5792965

alessandraV-3

Regarding the zip file upload you mention, how many files can the zip folder contain and should it have a specific name?
In the past I tried, but it didn't work.

In the meantime I am doing a test trying to upload just 1 single translated file and I get this:

Warning: preg_match_all(): Compilation failed: invalid range in character class at offset 11 in /home/aless889/public_html/wp-content/plugins/js_composer/include/autoload/hook-vc-grid.php on line 162

March 30, 2020 at 10:18 am #5793361

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

how many files can the zip folder contain and should it have a specific name?

The best way is to leave these filenames as they were when you downloaded them, but it should not matter because WPML should read data inside and create translations based on that.

I am not sure about that other errors, I only found this:
hidden link

But since the error points to visual composer (or bakery page builder, not sure what you have installed), can you reach out their support to find out more about it?

Regards,
Bruno Kos

March 30, 2020 at 6:03 pm #5798121

alessandraV-3

It doesn't work. Even if keeping the same name, when I upload a zip folder and not the single file I get this error:

"The archive contains one or more empty files.

Specialized Translators-translation-job-2634-2684/"

March 30, 2020 at 6:08 pm #5798131

alessandraV-3

If I rename the folder with a different name (e.g. "test.zip") absolutely nothing happens (I am not able to upload anything but no error message appears).

I need a solution. I cannot upload 4,600 files one by one.

March 31, 2020 at 6:05 am #5800837

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you send a batch of these zips, upload them to dropbox, so that I could check them and test? Talking about "The archive contains one or more empty files".

I will need WordPress credentials.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

Regards,
Bruno Kos