Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Shekhar Bhandari 2 years, 3 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
November 7, 2017 at 1:56 am #1422651

mikeD-5

If you follow the steps on this page you will be able to set up custom post type archive pages in Genesis
hidden link
This creates two text areas used on archive pages: the Headline and the Intro Text.

These sections do not appear in the String Translation module...at least I cannot find them. How can they be translated? This text is not mentioned on the page where you claim 100% genesis compatibility.

https://wpml.org/documentation/theme-compatibility/translate-genesis-framework-different-languages-using-wpml/

November 8, 2017 at 4:59 am #1423934

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello @miked-5,

Thank you for contacting WPML support. I'd be happy to help you on this.

So basically this issue happens where you are trying to use the following plugin features? Genesis Custom Post Types Archives, Is this right?

To help you further on this issue, I would need further information, so could you please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

Look forward to your reply.

Thanks

November 8, 2017 at 9:14 pm #1425164

mikeD-5

This is an issue you can easily reproduce on your end with a copy of genesis and a properly configured custom post type declaration, which I will provide if you need it. How can we speed this process up? Have you tried doing as I described yet?

November 8, 2017 at 9:17 pm #1425167

mikeD-5

And no, it's not a plugin. Please read the information at the link provided.

November 9, 2017 at 3:06 am #1425395

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

To further debug this issue,I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site on our local server for testing.

Look forward to your reply.

Thanks

November 11, 2017 at 9:30 pm #1427991

mikeD-5

To see the tex that cannot be translated, visit "Members" then Archive Settings

FTP access cannot be provided. Please duplicate the site locally if you have need to modify any files. Lets minimize the back and fourth if possible.

November 13, 2017 at 10:12 am #1428676

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Please follow the below steps and let me know if that helps.

1) Copy the following code and paste it in WPML->Translation Management -> Custom Xml Configuration.

<wpml-config>
    <admin-texts>
        <key name="genesis-cpt-archive-settings-portfolio">
            <key name="headline"/>
            <key name="intro_text"/>
        </key>
    </admin-texts>
</wpml-config>

2) Once you paste it in custom XML configurations, go to WPML -> Translation management -> Multilingual content setup and refresh the page,
3) Now go to string translation and translate the strings.

To find out more, https://wpml.org/documentation/support/language-configuration-files/

Let me know if this helps.

Thanks

November 15, 2017 at 4:56 pm #1431718

mikeD-5

These steps provide the ability to translate the labels. What I need is a way to translate the content. See the attached image: what you provided will translate "A" and what I need is to translate is "B"

November 16, 2017 at 1:03 am #1432047

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Have you tried those steps? those steps will give you the ability to translate the content of the fields, I tested on my test server and I can translate those, so could you please try it once? If you are still unable to translate it, could you please attach a screenshot showing what's showing in string translation.

Look forward to your reply.

THanks

November 16, 2017 at 1:09 am #1432051

mikeD-5

Maybe I'm not looking in the correct spot. Can you provide a screen shot of where exactly you see the string appearing?

November 16, 2017 at 1:28 am #1432056

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Please see the following screenshots and let me know if that helps.

Instead of searching for intro_text just search using the correct values there or search for domains as presented in the screenshot.

Thanks

November 16, 2017 at 1:31 am #1432061

mikeD-5

That text domain does not exist after entering the XML as instructed.

November 16, 2017 at 1:35 am #1432064

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I think you forget to perform to follow the below step, I performed this step on your site and it's showing perfectly now.

2) Once you paste it in custom XML configurations, go to WPML -> Translation management -> Multilingual content setup and refresh the page,

Let me know if this helps.

Thanks

November 16, 2017 at 1:35 am #1432065

mikeD-5

OK I understand the problem. The text domain you specified is dependant on the CPT in question. You chose to use 'portfolio' which made the domain 'genesis-cpt-archive-settings-portfolio' but in my case the CPT is 'members' Once I changed the XML to genesis-cpt-archive-settings-members, that text domain appeared. This looks like a solution to how to translate the text.

I'll do some further testing and if all is good, I'll come back and mark this as resolved.

November 16, 2017 at 1:39 pm #1432716

mikeD-5

OK, this does allow for the *entering* of a translated string. But the Genesis function is not using the translated string (specifically a function in genesis called

genesis_do_cpt_archive_title_description`

So the next step: how do we make genesis use these translated strings? Do I have to re-write the function to use a WPML function to pull the correct string?

Second, given that manually entering XML is a good system but not user friendly, are there tools to allow for the automated registration of these text strings?

wpml_register_single_string

maybe?