This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Kathryn 5 years, 8 months ago.

Assigned support staff: Andreas Neuber.

Author Posts
January 15, 2014 at 11:10 am #321512

Kathryn

Hi all -- I posted in an old topic (http://wpml.org/forums/topic/wpml-with-geo-mashup/) and then realized I should start fresh because that one is marked as resolved.

I'm having trouble getting GeoMashup and WPML to play nice. I've tried CodePeople Post Maps and have the same problem. Essentially, the map works fine in the primary language (English), but on the two secondary languages the screen is literally white. When I remove the GeoMashup (or CodePeople) shortcode, the pages load fine.

I tried the fix presented in the post link above, but still got the error message at the same line.

Anyone know a way around this? I'm trying to use a global post map only on one page of the site, so it's driving me crazy not to be able to get it to work because it's such a neat way to present the content. I'm not even trying to dynamically display the content -- for example, for the Spanish page to show only spanish stories on the map -- I just want the regular one to work across the board.

Any suggestions?

January 15, 2014 at 12:01 pm #321553

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Kathryn,

Looking at the previous post you mention, wonder why it was marked "resolved", its quite "un-resolved" 😐

# You mention a white screen. Thats an indicator for either not enough PHP memory or a "Fatal PHP Error"
Do you perhaps also have a "Fatal error: Call to a member function is_attachment()" ?

In case you don't see a "error_log" file in your installation, you can create one like this:
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/

2. Go to this page where you had the white screen, press a couple of times F5

3. Copy and paste the contents of error_log.txt on pastebin.com for us to see

--
http://wordpress.org/plugins/geo-mashup/

January 15, 2014 at 2:06 pm #321683

Kathryn

Hi Andreas --

I typed my message before coffee this morning, so let me give more info:

I get the white screen only with Code People, which is why I went to Geo Mashup, but still getting an error when trying to load the page. This is the error:

Fatal error: Call to a member function is_attachment() on a non-object in /home/caritas/public_html/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 4014

From the previous post I linked to, it seems like Ben's fix should work. But it didn't for me and I still get the same error.

January 16, 2014 at 9:33 am #322137

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hi Kathryn,

I see - thanks.
With the "Fatal error: Call to a member function is_attachment()" I need to check our plugin files.
Actually "is_attachment" is a core WP function and using the very same name is a bit dangerous - actually "icl_is_attachment" would be better..

January 16, 2014 at 10:31 am #322187

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Kathryn,

Researched a bit more and this goes very deep into the system.

Removing is_attachment() in our sitepress.class.php file is for sure *not* the solution.
Other things will break.

Would you mind providing us with credentials for your website and we have a closer look at the settings? For this purpose you should see a protected webform all they way down here in this thread. (it asks first for "Backup + Legal disclaimer")
Thanks in advance!

--
internal note:
> http://wpml.org/forums/topic/wpml-with-geo-mashup/#post-299233

> http://pastebin.com/Uqyhv5m1 --> line 7
> http://pastebin.com/JyFkFrJm --> line 10

> http://codex.wordpress.org/Plugin_API/Filter_Reference/posts_join
> http://codex.wordpress.org/Function_Reference/is_attachment

January 22, 2014 at 5:21 pm #326006

nikolayK

Same here. I need a solution too.

January 31, 2014 at 1:39 pm #331180

Kathryn

Sorry for the delayed response. I've circled back to this after trying to find a few different mapping solutions and having essentially the same problem with each.

Unfortunately, I'm not comfortable with trying to troubleshoot on the live site because of the fatal errors and other problems caused. The site gets a fair amount of traffic and I don't want to risk anything.

I'm testing in my local dev environment, but that's not helpful. I noticed in the post above that someone else is having the same problem. Perhaps they can share info for troubleshooting?

February 3, 2014 at 12:05 pm #332174

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Kathryn,

We've come to the conclusion that the best solution would be that we invite the author for a closer cooperation to make the plugin fully "WPML compatible". Therefore we are contacting the author now. Once he answers us we will start working on making the plugin compatible with WPML.

Based on our experience "quick fixes" take in effect longer than working together with the plugin author and address all issues at once. Its also much more "future-proof", no fixes are overwritten with plugin updates.

We are closing the ticket but we will keep it in our records and once the plugin is compatible with WPML we will notify you.

Best regards,

WPML support team
By OnTheGoSystems

February 3, 2014 at 8:18 pm #332539

Kathryn

HI Andreas,

I'm opening back up only because I want to emphasize that I've had the same issue with every single post mapping plugin that I've tried, not just GeoMashup. I believe he has the best plugin and it's the one that I'd vote for to work with, but you guys do need to know that it may be something within WPML causing the problem. It seems like all of these plugins that make use of Google API simply don't want to work with WPML.

I really need a way to map my content and this has been a huge, ongoing stumbling block.

The topic ‘[Closed] Geo Mashup and WPML’ is closed to new replies.