This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Yvette 4 months, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
May 28, 2019 at 4:00 pm #3908657

florisK-4

Hi,

I'm the web builder for my client's website: hidden link (LIVE) and hidden link (In Development)

The client has translated the original (English) website to 3 other languages with ATE. We built a slider using ACF and a repeater field. We can't get the slider to:

copy from original:
- the slider on/off swith value
- the background image

show the fields to translate:
- slide title
- slide content

The translator has already opened a support ticket which has been answered by Otto but as requested by the client, I'd like to pick it up from here. The subject of the existing ticket is: Translation Website Klieverik.com - 20190321_KLVRK_Website EN to DE, ES, FR. Please keep in mind, the support ticket is for the LIVE website, and I have a copy of it on my development URL.

What is actually making it a bit more tricky is the fact that we are have active translation jobs. I don't know if I can make changes to ACF, ACF Multilingual and the pages without messing up the translation jobs and process. Also I get notices of not being able to make changes because translations are in progress.

Could you help us get in the right direction?

- Setup the ACF fields
- Get the translations to copy the right field values from English
- Get the fields to show up in the ATE

May 29, 2019 at 3:18 pm #3916841

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Existing Ticket
I was not able to find this ticket. If you could provide the forum link, this would be more helpful. But, as I udnerstand, this is for the "Live" site. in any case.

2. This ticket
I understand that the focus of this ticket is to get the slider you built with ACF to
copy from original:
- the slider on/off swith value
- the background image

show the fields to translate in the ATE:
- slide title
- slide content

Correct?

3. Open translations
Yes, you should close ALL open translation jobs before making any changes to the ACF structure. But I imagine this is not an issue on the development site. Right?
You might open a new ticket for best practices on this matter once we have resolved point 2 above.

4. Next Steps
Please give detailed steps on how to see/replicate the problem on your development site. The optimal case would be to create the most simple example possible that demonstrates the issues you have.

Thanks

June 3, 2019 at 7:47 am #3939905

florisK-4

- Yes, point 2 is correct.

About cancelling translation jobs:
What do you suggest? Some jobs are open, some are completed, and others are waiting or in progress. The best would be to: end ALL translations without deleting already translated content. Then we would have the already completed translations in place.

When we get the slider to work properly, we can then send the missing bits of content for translation.

Could you advise me on how to get this done? We can test on the development site. When everything goes well I can repeat this on the correct website.

About point 4:
You ask for steps to replicate the problem. But the problem is: when I visit the english pages, my slider functions correctly. When going to one of the translations, the values of the slider aren't copied, so the slider is deactivated. Also, I don't see the ACF fields pop up in the translation editor as translatable fields.

June 3, 2019 at 9:02 pm #3946187

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

1. Completing jobs
You wrote: "..Could you advise me on how to get this done?..·"
As I said befoe, let´s first determine what is happening with the slider and why it is not working - then we can determine what best practices is for what you need to achieve.

2. Slider
Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

June 4, 2019 at 2:58 pm #3952947

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I reviewed the ACF configuration and saw that you had not set the corresponding system fields for the repeater custom fields to be "copy" (see image). If you read the documentation carefully, you will read that these fields must always be set.

Now the fields appear in the ATE.

Can you try translating them to see if they now appear in the translated page?

Thanks

The topic ‘[Closed] Get an ACF (repeater) Slider to work correctly with WMPL ATE’ is closed to new replies.