This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
October 3, 2019 at 12:20 pm #4687483

anneliW-2

Tell us what you are trying to do?
I upgraded from blog and registered a new domain harmonyhorse-hastbutik.se there I have a WooCommerce store.Translation doesnt seem to work and it says I need the WooCommerce multilingual but installing that gets an error. I already have WooCommerce installed.

What is the link to your site?
hidden link

October 3, 2019 at 2:01 pm #4688443

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

The Chat was disconnected and converted to a regular email ticket.
The FTP access are working for me. I will activate PHP debugging. But I still need access to the admin area to activate WooCommerce Multilingual and trigger the error.

Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Or allow me to create a user programmatically.

Best regards,
Jamal
Unfortunately, the provided access is not working for me. They seem

October 3, 2019 at 3:57 pm #4689627

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I changed the user language to English.
WooCommerce was installed but not activated, so I activated it and had to execute the WooCommerce wizard to complete activation. Please update the store information and currency in WooCommerce->Settings.

To be able to install WooCommerce Multilingual, you will need to register another key in your account page https://wpml.org/account/sites/
Then enter it in "Plugins->Add New->Commercial(Tab)", by unregistering the current key, and entering the newly created key.

Best regards,
Jamal

October 4, 2019 at 9:31 am #4694485

anneliW-2

I made a new key on the wrong site then. For Relationsbaseradridkonst.se - It is two sites that is not working and the original site is Relationsbaseradridkonst. I changed key but that didn´t work when I copied it to the string plugin.

The error of this site is gone but as said, the translation doesn´t work to update.

October 4, 2019 at 9:47 am #4694611
anneliW-2

For Harmonyhorse-hastbutik.se Please do it for me. I am not a programmer and do not understand. None of the two sites is working and it has been days. On the relationsbaseradridkonst.se site it didn´t help to make a new key. Please help. I don´t know why it is so difficult to work.

New threads created by Jamal and linked to this one are listed below:

https://wpml.org/forums/topic/get-the-translation-working-for-woocommerce/

October 4, 2019 at 11:26 am #4695225

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

As this ticket was created for (harmonyhorse-hastbutik.se), let's work on that site. I created another ticket to handle the issues in (relationsbaseradridkonst.se)

This website (harmonyhorse-hastbutik.se) has now a valid Multilingual CMS License. So you can install "WooCommerce Multilingual" without issues. But first, you will have to install WooCommerce.

Please go to Plugins->Installed plugins, locate WooCommerce, then click install(see the attached image). It will start the WooCommerce Wizard, where you will enter store information(address, currency, etc...) and follow the 5 steps wizard, it does not need programming skills at all.

After that, locate "WooCommerce Multilingual" bellow WooCommerce, and activate it. It will ask you to configure "WooCommerce Multilingual". Follow the 5 steps wizard, it does not need programming skills too.

For "relationsbaseradridkonst.se", I will be posting replies in the other ticket.

Best regards,
Jamal