This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by elieB-2 3 weeks, 1 day ago.

Assigned support staff: Bruno.

Author Posts
August 26, 2019 at 3:54 pm #4460253

elieB-2

Hello,

I have a translation problem with the get_fields part ($ product-> post-> ID); which returns the value null. What is strange is that for some language it sends me values but the new languages returns me null.

Here is the test page I'm working on:
hidden link
There is a var_dump at the beginning of the page.

I updated the plugins:
sitepress-multilingual-cms.4.2.7.1,
wpml-media-translation.2.5.2,
wpml-string-translation.2.10.5.1,
wpml-translation-management.2.8.6.2.

Thanks for your help.

August 26, 2019 at 9:43 pm #4461617

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. When I access the link you posted above it doesn't seem to display var_dump. Also, a "Page not found" page appears.

Regarding the issue you are reporting, are you sure you have followed the steps of our documentation for this new language?

If not, please look back at our documentation (https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/) and see if as for the other languages you are following the same steps for the new language too.

Thank you.

August 27, 2019 at 12:30 pm #4466481

elieB-2

Hello,
Here is the test page:
hidden link
and the translated test page where the "untranslated part" part does not appear :
hidden link

If I disable the plugin WPML Translation Management plugin I can translate the pages

Apparently it's the WPML Translation Management plugin when I change language when I'm on a product, it automatically switches to the url admin.php? Page = wpml-wcml & tab = products & prid and I have to use this module instead of switching to the product page in a new language. Off when I do translations with WPML Translation Management it does not save the values of customs fields correctly. However if I disable the plugin and I update the product sheet in different language without the plugin, the fields appear correctly.
I do not know if I'm clear?

August 28, 2019 at 2:15 am #4470395

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

September 3, 2019 at 12:07 am #4500183

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. Initially, for testing, I recreated "Custom Fields" for French, but the problem still persisted.

I noticed, however, when I accessed your site that WPML and its add-ons are out of date. For example, you are using version "4.1.4" when the current version is "4.2.7.1". Could you please upgrade WPML and its add-ons to the latest version to test?

Thank you.

September 3, 2019 at 1:32 pm #4504821

elieB-2

Hello,
I made the updates;
It's always the same problem :
hidden link
the part "untranslated part" of this page hidden link is not present

September 4, 2019 at 12:06 am #4507549

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thanks for updating the plugins. I downloaded a copy of your site with Duplicator so I can check it in my test environment.

This is probably happening for some option that should be copied but is marked for translation. I will test your site in my testing environment and soon I will contact you.

Thank you.

September 7, 2019 at 2:59 am #4528261

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello

Just as an upgrade, I forwarded your ticket to 2nd tier support. They will check your site and as soon as I have news, I will update you.

Thank you.

September 18, 2019 at 7:55 am #4593383

elieB-2

Hello

Have you any news ?

September 19, 2019 at 2:13 am #4600543

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Sorry for the delay. Yes, 2nd tier support tested this and following the steps below it worked correctly:

- Go to the edit screen of the page - original language
- Scroll down to "Multilingual content setup" then click on "Show system fields"
- Set the "_blocks_before" field as "copy" then click on apply
- Do a small modification on the page content and save
- Translate the product (using CTE) then save

Please, could you check if by following the above steps the problem is solved?

Thank you.

September 30, 2019 at 10:10 am #4663607

elieB-2

Hello,
I tested this on the working area. I request validation before closing the ticket
Thank you