This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 31, 2019 at 9:34 am #4313333

eduardoS-16

I am trying to:

Setup the translation of my website from english to german.
I have already my pages translated to german and they work fine, except the homepage that when you change it to german it shows a index page.. ( hidden link) The other pages works fine and their translation too. And my home page in english (original language) works fine too..

Link to a page where the issue can be seen: hidden link

I expected to see: My home page hidden link in german

Instead, I got:a index page

July 31, 2019 at 2:05 pm #4315147

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

August 1, 2019 at 11:15 am #4321011

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I visited WPML -> Languages -> Language URL format -> And I see that you had 'Different languages in directories' option selected, but below this option there is a red warning that says this option won't work in your case. If you click on the 'Details' link you will see more information about this warning.

In this case I selected 'Language name added as a parameter' option and re-saved the permalink structure and the issue is gone.

Regards,
Carlos

August 1, 2019 at 11:22 am #4321049

eduardoS-16

Good day Carlos,

Ok, but i don't want to have that parameter in each url.. I prefer to have the by directories. and if this option is not possible i would prefer per subdomain. This is not a solution for me.

Regards Eduardo

August 1, 2019 at 11:25 am #4321105

eduardoS-16

And subdomain says that is not valid even that i already created both subdomains...

August 1, 2019 at 6:12 pm #4324617

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Eduardo,
I understand your concern.

Please visit this link where you will find our official documentation regarding this subject: https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

I also recommend you to contact your hosting provider if needed.

The steps above should solve the issue.
Regards,
Carlos

August 1, 2019 at 9:41 pm #4325303

eduardoS-16

Apparently the URL rewriting is enabled and i added the code that you recommended in the wp-config. but the bluehost support insist that there is something in your code that is not working. What can i do now?? 🙁

Regards

August 1, 2019 at 10:32 pm #4325523

eduardoS-16

My issue is resolved now.

August 5, 2019 at 11:53 am #4340237

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
I'm sorry for the delayed message.

For some reason I din't see your message and lost track of this ticket. Could you confirm that the issue is solved? Or let me know if you still need assistance?

Regards,
Carlos