Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Lauren 4 years, 11 months ago.

Assigned support staff: Lauren.

Author Posts
August 11, 2016 at 1:22 pm #999535

jonathanF-3

We are getting 404 on some translated page. While some page just work as expected, other are getting 404.

We already did the "cleanup" by pressing a couple button in the WPML settings as suggested in multiple other post.

Is there a way we can provide the website URL in private without having to wait for the first reply ? This is really annoying....

August 11, 2016 at 2:48 pm #999664

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I have marked the next reply as private so that you can share the link in private. Also, please go to Settings -> Permalinks and change the structure to default and see if this resolves the 404 pages. If not, please try testing with a minimal setup (all non WPML plugins deactivated and temporarily switch to a default theme such as Twenty Fifteen) and see if this resolves the issue.

August 11, 2016 at 5:29 pm #999912

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I checked your site and can translate back and forth between French and English on a number of pages. Could you please give me an example of a page where you are seeing the 404 error? I will mark the next reply as private to keep the URL hidden.

August 11, 2016 at 6:33 pm #999998

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The problem with this URL structure is coming from the fact that you have a custom post type "Team" that already uses the slug "team". If you change your team page URL to something different (for example, I just added the number 1 after it),then you can see that the page loads correctly: hidden link

If you want to use 'team' for your Team page, then you will need to change the slug of the Team custom post type.

Please let me know if you need any further assistance and I will be happy to help.