This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bruno 3 months, 1 week ago.

Assigned support staff: Bruno.

Author Posts
July 6, 2019 at 12:48 am

jasonS-8

I am trying to: activate sitepress

Link to a page where the issue can be seen:
hidden link

I expected to see: nothing no errors

Instead, I got:
Warning: preg_match(): Unknown modifier '(' in /home/content/p3pnexwpnas02_data03/92/2940092/html/wp-content/plugins/sitepress-multilingual-cms/inc/absolute-links/absolute-links.class.php on line 176

July 6, 2019 at 1:23 am #4154211

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. It seems that perhaps the installation of WPML was not done correctly. When I try to update the page, this error message is displayed:


WordPress database error: [Unknown column 'word_count' in 'field list']
SELECT word_count FROM _icl_string_packages

From the error message, it looks like the "word_count" column is missing. You may need to re-create these tables. Have you done any translation? If not, please follow the steps below:

- Backup your site;
- Click on the WPML > Support > Troubleshooting
- Scroll down and look at the "Reset"
- Check the "I am about to reset all translation and language data." option
- Click on the "Reset and deactivate WPML" button
- Click on the Plugins > Installed Plugins
- Enable and configure the WPML again

Following the above steps, does the problem still persist?

Thank you.

July 6, 2019 at 2:10 am #4154327

jasonS-8

hi, yes I have done translations.... will this affect them?

July 9, 2019 at 7:40 pm #4174103

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Yes, because the translations would be lost. In this case, the best option should be to create this column manually to see if the site will work correctly.

Probably this problem happened because you upgraded from a fairly old version, 3.3.5, to the latest version and for some reason, the table was not updated correctly by adding the required column (word_count).

This should be the complete table: https://pastebin.com/WsNZwkai. Note that the prefix I'm using is "wp_". You must update according to your database.

If you want I can do this for you to check if the problem will persist, but in this case, I should need to have access to PHPMyAdmin.

* Note that when I try to access your site, it appears that the login you previously provided is invalid. Maybe the user you created for support has been removed.

Thank you.

The topic ‘[Closed] Getting errors when I activate the main plugin’ is closed to new replies.