This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.43 hours from now. Thank you for your understanding.

This topic contains 1 reply, has 2 voices.

Last updated by Riffaz 4 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
June 8, 2019 at 8:32 am #3980715

prashantK-3

Hi,

with wordpress 5.2 feature, it sends you email with some bugs and here we got something related to wpml

An error of type E_ERROR was caused in line 130 of the file /kunder/zskmkf_2961/vivama_5016/public/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php. Error message: Uncaught TypeError: Argument 1 passed to WPML_Media_Post_Images_Translation::translate_images_in_post_content() must be an instance of WP_Post, null given, called in /kunder/zskmkf_2961/vivama_5016/public/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php on line 107 and defined in /kunder/zskmkf_2961/vivama_5016/public/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php:130
Stack trace:
#0 /kunder/zskmkf_2961/vivama_5016/public/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php(107): WPML_Media_Post_Images_Translation->translate_images_in_post_content(NULL, Object(WPML_Post_Element))
#1 /kunder/zskmkf_2961/vivama_5016/public/wp-includes/class-wp-hook.php(288): WPML_Media_Post_Images_Translation->translate_images(70049035)
#2 /kunder/zskmkf_2961/vivama_5016/public/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL,

Please look into this and sort this error

June 9, 2019 at 5:28 am #3982357

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

There could be many reasons for this.
Do you see this error if you disable the "WPML Media Translation" ?
Did you delete any image or menu or any pages recently?

Let me know please.

Regards,
Riffaz.

The topic ‘[Closed] getting some error from wordpress related to wpml’ is closed to new replies.