This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by michaelK-3 4 years, 5 months ago.

Assigned support staff: Ahmed Mohammed.

Author Posts
March 18, 2015 at 7:33 pm #581469

michaelK-3

I am trying to: Add translators through WPML plugin

I visited this URL: WordPress Admin -> WPML -> Translation Management -> Translators -> Add Translators -> Selected iCanLocalize -> Add Translator

I expected to see: An iCanLocalize login screen

Instead, I got: "You do not have sufficient permissions to access this page"

March 19, 2015 at 9:43 am #581842

Dimitris
Supporter

Timezone: Europe/Athens (GMT+03:00)

Hi Michael,

I believe that we currently don't have any issues with connection to ICanLocalize.

Although, because we have "pushed" some changes to our servers for this connection, I would please ask you to provide us WP and FTP access in order that we resolve this faster 🙂

Regards,
Dimitris

March 20, 2015 at 10:40 am #582821

Dimitris
Supporter

Timezone: Europe/Athens (GMT+03:00)

Hi Michael,

I can see that there is a 500 internal server error. I think this has something to do with the validation of your site_key in our ICanLocalize server but I can also confirm from "our side" that your site is properly registered. In conclusion, I will need to investigate this further 🙂

Is it possible that you provide us with a duplicate of your site? You could use the Duplicator plugin and upload a copy of your site to Dropbox or Google drive. After you upload, please add the link in the private fields available in your next reply.

Regards,
Dimitris

March 26, 2015 at 11:29 am #588416

Dimitris
Supporter

Timezone: Europe/Athens (GMT+03:00)

Hi again,

Sorry I missed that in the first time but could you update String translation and Translation management to latest versions?

Let us know how this goes 🙂
Dimitris

March 26, 2015 at 3:16 pm #588629

michaelK-3

Hi Dimitris, we are actually using version 2.1.1 for String Translation and 1.9.11 for Translation Management on our production server. Our test site I sent you must be using an older version, my apologies. Any other ideas? It still has that behavior of this site using the latest version or the slightly older version.

March 27, 2015 at 11:30 am #589262

Dimitris
Supporter

Timezone: Europe/Athens (GMT+03:00)

Hi Michael,

This is a tough one 🙂 I could test the connection with the Icanlocalize service and it seems that your server is able to access the server but I don't understand (yet) why you can't add translators or access the ICL frame at all.

If possible, I would like to ask you to try and turn-off all your 3rd party plugins. If you're still having issues I will need to test your site locally or in one of our test servers.

Could you please provide us a copy of your site? You could use duplicator and upload your copy to Dropbox, Google drive or at any service your prefer.

I will need this in order to discuss this case further with our ICanLocalize specialized developer 🙂

Regards,
Dimitris

April 2, 2015 at 2:27 pm #592954

Dimitris
Supporter

Timezone: Europe/Athens (GMT+03:00)

Hey Michael,

Thanks for the duplicate.
I'm onto this and discuss it with our devs.

I will have some results the latest by tomorrow.

Cheers!

April 6, 2015 at 3:38 pm #594352

michaelK-3

Hi there,

Just wanted to check in on the status of our issue. Thanks!

April 7, 2015 at 9:54 am #594828

Ahmed Mohammed
Supporter

Timezone: Europe/Rome (GMT+02:00)

This is Ahmed and I'm taking care of this, hope it's OK!

Please accept our apologizes for this unintentional delay. Looking at your admin panel of the test site, I could see many warnings about "permissions" with other plugins and WordPress itself. You may need to re-check your server permissions.

However, I'm downloading the snapshot right now and I'll be back to you so soon.

April 7, 2015 at 11:53 am #594927

Ahmed Mohammed
Supporter

Timezone: Europe/Rome (GMT+02:00)

According to the attached screenshot, I was able to add translators with your installation after using DEFAULT wp-config.php and .htaccess files.
On your test site and after creating a new admin, I got a bunch of warnings/errors from WP Rocket and other permissions.
You can test this, and please do it, because I don't want to share a public screenshot contains such important info about your folder paths.

To sum up, you need to check files permissions on your server, then you may need to disable WP Rocket and check if everything is working fine.

April 22, 2015 at 5:22 pm #604295

michaelK-3

We did a new install of wordpress and things are working now. Thank you so much for your time!