This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 3 voices.

Last updated by Andrey 1 year, 5 months ago.

Assigned support staff: Andrey.

Author Posts
September 14, 2017 at 11:26 am #1371804

emelieC

I am using Global Addons for product variations etc. But it is not translating properly.
Before the update I could see my global addons in Swedish, if Im on the Swedish version and English on the English version. Now everything is in English.

We have used String translation to translate several add ons and I can find them in the
wc_product_addons_strings

218 currently.

There are too many strings of the same name.
For instance the sentance "Invändig Gravyr" (which means "Inside engraving) appears 8 times in string translations and all are marked as "translation complete"

If I make a change in this Global addon, it puts the English version on my front end. and it has created a new string which needs to be translated and marked "translation complete"
Then it shows the Swedish version on my front end.

If I write the global addon in Swedish, and then translate it in strings, when I return to Global addons it shows in English.

It is really weird behaviour and something is wrong.

September 14, 2017 at 4:27 pm #1372227

SergeyR
Supporter

Dear emelieC,
It's normal behavior that you need update translation for edited string, but it shouldn't create new string in String translation module.

Can you please check one more time if it's updated previously registered string ( with status "needs update" and unchecked flag "translation complete" for translations ) or it registered new string with the same value in translations ( then it looks like a bug )?

I have also checked with latest versions of plugins to make sure if it's look good.

September 15, 2017 at 11:29 am #1373231

emelieC

Hi Sergey,

I think it is a bug.

Because, every global addon on the Swedish backend, is now in English. and if I go to String Translations where the Swedish flag is, is the English text and then the translation for english is also in english.
Very strange.

So if I then put the text in Swedish again in the global addon, it creates a new string in string translations that needs to be translated, (or the english version is in swedish), and that string already exists in string translations. I now have lists of the same words 12 times.

Also updated previously registered strings are registered as new strings, but unchecked as translation complete.. So I just get the same string 10-20 times....

How can this be solved? Its very frustrating.

Thank you

September 20, 2017 at 7:02 pm #1378327

SergeyR
Supporter

Sorry for delay,
I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Thanks

September 21, 2017 at 1:14 pm #1379184

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Hello,

This is Andrey here from WPML support.

Could you please also update your WPML plugin to the latest version 3.8.1 and add-ons as well as Woocommerce Multilingual to benefit from the latest bug fixes and improvements? This may not necessarily resolve your problem, however, in order to troubleshoot the issue best we need to work on the latest code available.

You can check the latest released versions under "My Account -> Downloads" on this site. Instructions to update can be found here: http://wpml.org/faq/install-wpml/

Please remember to backup your database first before you proceed! You can use a plugin for this if you like (example: http://wordpress.org/plugins/duplicator/)

Let me know if the issue persists after an update has been done.

September 25, 2017 at 3:02 pm #1382459

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Thank you for providing the information! In general, the standard approach is to write the strings in English first and then, translate them to secondary languages because initially all the plugins and WP itself are written in English. But you also able to change the original language for a domain in WPML >> String Translation when choosing the option "Languages of domains" if it needed.

As far as I can see in your case, you need to do the same.

Would it solve the problem if you write them in English first? If not, please give me more details so I can follow and be better of help.

September 29, 2017 at 6:23 am #1386826

emelieC

Hello Andrey,

There is not much more details I can give you. I have explained the issue in previous posts.

You do have access. Please check what might be the problem.

Duplicator is installed. If you set up a copy of the site you can play around to see what is the issue and how it happens. Maybe you can then understand what I mean and fins a solution.

Here is how to replicate (IMPORTANT THAT YOU MAKE CHANGES ONLY ON YOUR DUPLICATOR COPY - NOT ON LIVE SITE!) :

1. Go to Products > Global Addons.

2. Click edit on This option: "Utvändig Gravyr (Ingår)" (Used on the Silver Message product category)

3. Then go to a Silver message product like: hidden link

4. On that product Please look at the front end and notice that it gives a correct Swedish version: hidden link

5. The Default Language of the Global Addon domain is in Swedish: hidden link

6. Now you look at the Global Addon Edit page again for "Utvändig Gravyr (Ingår)". Notice that the option is written in English even when you are on the Swedish version. It should actually be displaying in Swedish (As that is how we have entered it)

7. Lets say we want to make a change in the Swedish version, which is the default language of the domain. This would not be possible since the Swedish version is not displayed.

8. So since we are saving the strings in Swedish; we should be able to change the English text to the corrected Swedish version. Make any change and then save.

9. Please now check what u saved. On the edit page it has gone back to English and it seems it was not saved. Why does it show it in English when language of domain is in Swedish and I am on the Swedish version of admin? Am I forced to use English as a domain? It has always show in Swedish before. Especially right after being saved.

----

Another thing is that when I update a translation it now shows in Swedish in string translator and the old ones in english. How come? Could this be related issue?

Our website did have a lot of issues since an old update where you started allowing us to set the default language of strings. The site seems to be mixing up languages and this is one of those examples where things do not seem to work property. From time to time we encounter different things like this.

Hope you can help!

Kind regards,

Marcus

September 29, 2017 at 11:29 am #1387191

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Hello Marcus,

Thank you for providing super details steps. I went carefully through them using the duplicator package I have got.

Let me start from the step six as I think it is where the confusion starts from.

6. It doesn't matter in what language the option is written, afterward, you need to translate it into a second language in WPML String Translation or on the WooCommerce product translation page (wp-admin/admin.php?page=wpml-wcml).

You don't suppose to switch the language using the switcher on top to choose the version of the page. You wrote that it has been working before, but I can't say why this worked (it shouldn't be). I also consulted with our compatibility team about this.

Here's an article explains the steps:
https://wpml.org/documentation/woocommerce-extensions-compatibility/translating-woocommerce-product-add-ons-woocommerce-multilingual/

7 -8. If you need to do the change to the original text, then you need to go to the Global Addon Edit page and apply the change. After, go to WPML >> String Translation and correct/finish the translation.

9. Do not pay attention to the version of language the switcher on top shows when you are on the Global Addon page. The most important is to put the proper version of the text. E.g., the language of the domain is in Swedish. It means that all original strings should be in Swedish, then translated into English. Currently, I see you have English text there (the Global Addon page), but the language of the domain is in Swedish.
One issue I have noticed and I am going to report about it that when you save new text on the edit page, the English version is back (as you wrote). You need to save it twice so it finally will be saved.

You are not forced to use English for the wc_product_addons_strings domain, but then you need to be sure that the original strings have been added in Swedish.

Another thing is that when I update a translation, it now shows in Swedish in string translator and the old ones in English. How come? Could this be related issue?
I think, it should be OK if you add text in the correct language to the Global Addon options to correspond the domain language.

Thanks,
Andrey.

October 3, 2017 at 6:41 am #1389510

emelieC

Hello Andrey,

The steps you have suggested have always been taken.

No attention has been taken to the language switcher on top bar.

We have always entered the values in Swedish, then translated them in String translator.

When entering the Global Add-On edit page, the values have been showing in Swedish.

However, now, when having translated them in string translator, they show up in English.

Please try doing the exact steps I showed in previous post.

What I am saying is that if I enter them in Swedish they should be there in Swedish.

Then the english translation should be changed in string translator.

This is not the case!

When adding it in Swedish it then switches the data to English.

But in String translations it is in Swedish and only the English data can be changed.

Can you not see my point?

...Please

If not then read through everything again and make a real effort, because I doubt that I can specify the problem better.

Thanks

October 3, 2017 at 12:53 pm #1390100

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Thank you for your feedback! I've got your point, but I still think there's some misunderstanding. Could you please point me on the screenshots where the issue comes? If you can, please upload even a screencast showing me the exact problem.

To make sure that I understand you correctly, I made a short video to show you my steps. Let me know if they are right or not. Please find the link inside the private reply where you shared access credentials, and I sent it to you also via email.
As far as I can see this works fine, I don't see the issue. You are welcome to comment the screencast I made.

I would love to help you, but I need to understand this better.

October 10, 2017 at 8:54 am #1396355

emelieC

Hello,

Here is a video explaining the issue:

hidden link

Actually when saving it twice, it does seem to change, however, why would I need to do everything twice?

Thanks!

October 10, 2017 at 8:58 am #1396360

emelieC

So for instance, right now, it was super annoying:

1. I see that the texts are in english
2. I see a misstake and correct it
3. This gets added to string translator in Swedish.
4. I now have the english translation as Swedish.

Its just a mess to be honest. I don't get it.

October 11, 2017 at 12:03 pm #1398017

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Hello Marcus,

Thank you for the video! Yes, I see what you mean and the same issue I got on a local copy. Saving twice is a compatibility issue which is I already have reported to our compatibility team and mentioned you few posts above. I believe on this step the confusing/mess comes from.

I'll update you here, as soon as I have any news on this. Most likely, we'll need to contact the plugin's author and work with him on solving this.

But a temporary workaround 'saving twice' should be working for you. In the meantime, could you please test this again but to make sure to save twice ( in a row ) absolutely the same string? Like I did in a video.
After, the string should be correctly displayed in WPML String Translation.

Let me know about the results.

October 12, 2017 at 1:55 pm #1399262

emelieC

Not sure what you mean. I have provided my details, please maka a test and see what happens.

Just make sure everything is the same as it was before.

I hope you manage to reach the plugin authors so this can be solved.

Thanks!

Kind regards,
Marcus

October 12, 2017 at 4:59 pm #1399469

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Thanks Marcus. I made another video for you to show how to save the text. I put the new video to the private reply (the same I did before). The workaround is to save the text twice until we have a permanent solution.
I returned everything back.

I forwarded the details to our Themes & Plugins Compatibility Team and they will contact the author. Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

You will be notified the moment we have any news on this.