This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Global containers does not appear to use in other languages Solution: Client solution: " I first set "element_category" to untranslatable and it solved the problem without having to add the code to a .php file. It surprised me because I thought you had already checked the taxonomy translation options! ...but anyways, it seems to have solved the issue."

If it doesn't work, do this up the point: https://wpml.org/forums/topic/i-cant-save-a-container-in-the-secondary-language-of-my-avada-site/#post-3856165

Here is a video as well: https://drive.google.com/file/d/1v-Sr3hdZJPS14DQT9bHFaiWq4jkCpN5b/view

You would load that code from the root WordPress intallation, load it like http://localhost/new7/fix.php and then remove it.

This topic contains 3 replies, has 2 voices.

Last updated by Bruno Kos 3 weeks, 1 day ago.

Assigned support staff: Bruno Kos.

Author Posts
September 27, 2019 at 9:47 am #4652811

jesusM-15

Hello. I save containers as global in the English version of the website (the original version is in Spanish) and then when i try to add them they do not appear (image attached: "Captura"). However, i go to Fusion Builder library and they are shown (image attached: "Captura1")

September 27, 2019 at 1:12 pm #4654379

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you do this up the point?
https://wpml.org/forums/topic/i-cant-save-a-container-in-the-secondary-language-of-my-avada-site/#post-3856165

Here is a video as well:
hidden link

You would load that code from the root WordPress intallation, load it like hidden link and then remove it. It fixed my localhost installation.

Regards,
Bruno Kos

September 30, 2019 at 8:44 am #4663039

jesusM-15

Hello Bruno. I first set "element_category" to untranslatable and it solved the problem without having to add the code to a .php file. It surprised me because I thought you had already checked the taxonomy translation options! ...but anyways, it seems to have solved the issue.

September 30, 2019 at 9:13 am #4663213

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Great to hear that! I apologize for putting you through all the trouble with Duplicator packages and stuff, now that we know how simple the solution is. However, sometimes we need to go very far with debugging even though the solution is one click away 🙁

I am marking this thread as resolved (unless you confirm that it isn't it, but I got an impression that this, and also because it works on my localhost as well).

Regards,
Bruno Kos