This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by gloriaC-7 5 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 26, 2019 at 10:08 am #3689607

gloriaC-7

Tell us what you are trying to do? How to setting Global language switcher options?
1.There is no setting page at my WPML setting screen.
2.I check my website and only main page show mutillangue options. When click other page, it only english.
3. I don'w want to show any word with language flag(ex. english) How to modify it?

Is there a similar example that we can see?
yes
What is the link to your site?
hidden link

April 26, 2019 at 11:34 am #3690365

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue,

Please follow the below steps
1) The language switcher setting will be able at WPML > Language > Menu language switcher
2) Click on the pencil icon to edit the language switcher settings
3) In the settings popup Select Only the "Flag" to be displayed

To change the language flag for Taiwanese
1) Goto WPML > Languages > Site Languages, click on "Edit Language" link located below the languages list
2) In the edit language screen, You will have the option to add a custom flag for Taiwanese language

I hope this helps you better. let me know if you need further assistance.

Kind regards
Raja

April 27, 2019 at 3:38 am #3694475

gloriaC-7

hi,

The flag not show after done the setting you wrote to me. Can you enter my dashboard to setting for me?

April 29, 2019 at 5:50 am #3700103

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I have enabled the private fields, Please share your site login details.

Kind regards
Raja

April 30, 2019 at 1:37 am #3707137

gloriaC-7

send you the flag in case you need it, thank you.

April 30, 2019 at 6:09 am #3708045

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have fixed as per your request.

I have changed the language switcher style from dropdown to List of language in WPML > Languages > Menu language switcher.

I hope this solves your issue.

Kind regards
Raja

April 30, 2019 at 6:46 am #3708239

gloriaC-7

Dear Sir,

Thank you. But still not each page was settle down. When click About / News / Contact only show english. Did this management not one setting for whole website?

April 30, 2019 at 6:51 am #3708249

gloriaC-7

and same problem at footer each page.

April 30, 2019 at 6:58 am #3708373

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Gloria,

Language flag will be visible only if there is a valid translation available for the page. If you don't see the flag on a particular page then the page is missing the translation which means the page is available only in one language. (contact page is available only in English and hence you see the English flag, same applies to all other pages.)

I hope this clarified you better.

Kind regards
Raja

April 30, 2019 at 7:21 am #3708621

gloriaC-7

Oh,understand. Thank you for your help. By the way , can you teach me if I want let flag show by Drop-down menu. The setting tutorial , many thanks.

April 30, 2019 at 10:52 am #3710463

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Gloria,

You change the language switcher style from WPML > Languages > Menu language switcher, Click on the pencil icon to edit the settings. In the Language menu items style select "Dropdown". Please refer to the video for more clarify hidden link

Kind regards
Raja

May 2, 2019 at 1:49 am #3720501

gloriaC-7

My issue is resolved now. Thank you!