This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.04 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by Bruno 3 months, 1 week ago.

Assigned support staff: Bruno.

Author Posts
June 27, 2019 at 7:32 pm #4102631

alistairM-4

Hello,

We've had WPML installed for a few months now.

I have a couple of issues, but I believe I have resolved one. However, I would like to check with yourselves please.

1) Google is crawling both my English UK and English US site, it seems confused (Please see SEMRush screenshot hidden link). I havent configured anything in Webmasters, Robots or htaccess since installation as I understand that isnt needed? (Please let me know if this is correct)

By looking at other tickets related to this - such as https://wpml.org/forums/topic/multilingual-site-google-search-result-to-show-in-own-language/ my issue may also be as I have the Browser activated (Please see screenshot of my WPML settings hidden link).
I have now de-activated this! Is there anything else you would recommend?

2) Unsure if Languages are correct.
This might be a related issue, I wonder if you could advise if I have these correct for US language? hidden link

Thank you.

Alistair

June 27, 2019 at 9:46 pm #4103021

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us.

1. By default, you do not have to set anything up for Google to crawl your site properly. Using the redirect feature may cause a problem with the Google crawler. You can see more in our documentation: https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/

That is, if some indexing is not correct or if Google is confused, the best option is to keep the redirect option disabled.

2. In the "hreflang" option, ideally, you could use "en-us" and "en-gb". You can see more in this documentation: hidden link

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

June 28, 2019 at 8:26 am #4105537

alistairM-4

Ok thanks, I have set the hreflang to en-gb and en-us rather than en_GB and en_US - that seems to be correct now?

My Default locale is still en_GB and en_US, is that correct?

Thank you

July 1, 2019 at 9:51 pm #4122239

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

>>> My Default locale is still en_GB and en_US, is that correct?

Yes, that would be correct.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

July 8, 2019 at 8:19 am #4159851

alistairM-4

Hello,

Following the changes made above I had some errors flag up on my SEMRush audit of the website, I've read through a few of the closed tickets but theres quite variety of responses and how to fix, would you be able to advise for our particular site? It only seems to be impacting a handful of pages but it could be because I hit my SEMRush crawl limit.

Thanks,

Al

"Conflicting hreflang and rel=canonical
The canonical tag on this page points to a different language URL. When using canonical tags on your website along with hreflang attributes, you should make sure to specify a self-referential canonical tag."

"No self-referencing hreflang
If your page doesn’t contain a self-referencing hreflang in its set of hreflang attributes, those attributes may be ignored or interpreted incorrectly.
Include this page’s URL and language code in your set of hreflang attributes."

July 10, 2019 at 7:19 pm #4184147

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

It seems to me to be correct. The canonical tag is pointing to the same URL as expected. I've seen this just by looking at the source code of your site. I'll attach an image for you to see.

That is, according to the screenshot you posted, the problem is that the canonical tag would be pointing to another language, but they are not. It is pointing to the same language URL, correctly. This is the expected behavior of the canonical tag.

Thank you.