This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bruno 2 months, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
July 22, 2019 at 5:53 pm #4260563

erdoganE

Hello there,

We have been using the WPML plugin for a long time. And we have learned for a long time that Google is having troubles on index results.
When the WPML plug-in and extensions were active, the hidden link link was giving a "no index" warning on the Google Console. It was not indexed on Google.

We've disabled and tested many plug-ins, and when the issue is not resolved, we disabled the WPML plug-in. The problem was solved when we tried it on Google Console. And we've seen you get indexes on Google searches. In addition, the English content of our page was indexed on Google but our Turkish pages were not indexed. When people search on Google from Turkey, we see that our English pages indexed.

We have seen that all these problems are caused by the WPML plug-in and extensions. Google has seriously damaged our business and results in customer losses. We have disabled your plugin at this time. We demand immediate resolution of these problems.

We thank you.

July 22, 2019 at 11:39 pm #4261715

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Could you please enable WPML so we can test?

Also, were you using the WPML redirect feature? If so, this may cause problems with indexing your site. Please, see the explanation in our documentation: https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/

After enabling WPML, please, what is the version of WPML and WP are you using? I would like to know more about your installation. Can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Thank you.

July 23, 2019 at 10:22 pm #4269167

erdoganE

Hello,

We have re-enabled WPML plugins on our web page.
Wordpress Version: 5.2.2
WPML Version: 4.2.7.1

We use it in the latest versions. In addition, we have done taking into account the links mentioned. Even our SEO Expert friends did not understand the problem. So we're a comprehensive team. But your language extension has caused us to lose many customers. We ask you to intervene directly and solve the problems permanently. We thank you.

July 24, 2019 at 7:41 pm #4277193

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

As I explained above, when you enable the redirect option, this can cause problems with Google indexing. This does not always happen, but it can happen. For this reason that we even display an alert when you enable this option. I will attach a picture for you to see.

If Google is not crawling your site correctly, the first thing to do is to disable this option and wait a few days/weeks to see how Google will crawl your site. To do so, click on the WPML > Languages > Browser language redirect and select the "Disable browser language redirect" option. Click on the Save button.

Again, please, see the explanation in our documentation: https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/

That is, you must disable this option and wait to see if the problem will persist. But this will probably be fixed.

Thank you.

July 24, 2019 at 11:08 pm #4277847

erdoganE

Hello there,

Okay, I get that. Why did the hidden link page give a "noindex" warning on the Google Search Console? Somehow Google did not index this page and many pages. This problem should be caused by the WPML plugin. In other words, pages that are not indexed on Google Console give a "continuous redirect" error and our pages are not indexed. Can you clarify that?

Thanks.

July 25, 2019 at 9:11 pm #4286085

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

No. This issue is not being caused by WPML. As you can parse directly from your site, no "noindex" tags are being created. You can also use some external service to test this. For example: hidden link. As you can see, "noindex" is not being added to your site.

The WPML doesn't even add this kind of tag to the header. What may be happening as explained earlier is because of redirection. At the moment you should disable it and check how Google will behave. Or if it was added in the past, it certainly wasn't WPML.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.