This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by kristaT 2 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
July 23, 2019 at 11:53 am #4265751

kristaT

Tell us what you are trying to do? I want to rank for keywords in English as well as German. It's as if the German page doesn't even exist for Google.

Is there any documentation that you are following? I don't know if I should be following these. I thought I would check with you first. I have been using WPML since the very beginning. hidden link
hidden link

Is there a similar example that we can see?

What is the link to your site? hidden link

July 23, 2019 at 5:58 pm #4268569

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. I noticed that apparently, you are using the WPML feature to do redirects automatically depending on the user's browser.

This can cause issues with the Google crawler. You can see more details in our documentation: https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/

At the moment, I should recommend that you disable this option for a few days/weeks so you can see how Google will behave. To do this, follow the steps below:

- Click on the WPML > Languages > Browser language redirect
- Select the "Disable browser language redirect" option
- Click on the Save button

After that, wait a few days and see how Google is crawling your site.

Thank you.

July 23, 2019 at 6:00 pm #4268573

kristaT

Bruno, I notice you listed the livingoncookies.NET website, which is SUPPOSED to redirect to livingoncookies.COM. The .com is the website I'm having issues with.

July 23, 2019 at 6:09 pm #4268607

kristaT

I disabled the browser language redirect as you suggested.

July 23, 2019 at 6:10 pm #4268611

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I am looking for the link you posted above. Accessing the URL (hidden link), for example, was redirected to the hidden link) domain - without the language code.

Now that you have disabled the redirect feature you need to wait a few days to see if Google will crawl your site correctly.

Thank you.

July 27, 2019 at 2:01 pm #4293563

kristaT

Hi, it's been a few days and Google is still unable to find my German content. What should my next step be?

July 29, 2019 at 5:37 pm #4302579

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I see that Google has already indexed several pages of your site in German. I will attach a picture for you to see.

Some of these pages were even indexed last week. Note that now that pages are already being indexed, to improve the relevance of pages, this should be SEO work (on-page and off-page, link building, etc.). This is no longer related to WPML.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

July 29, 2019 at 6:53 pm #4303147

kristaT

Then I will say Danke schön for now and thank you for your help! 🙂