This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 3 voices.

Last updated by rawaJ 3 years, 6 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
March 2, 2016 at 2:31 pm #828282

merijnK

I have a problem with google maps if i switch language , the maps is only visible at the main language but not at the other translations,
I am using advanced custom fields plugin for google maps.

Wordpress is version 4.4.2
Advanced custom fields is version 4.4.5
WPML Multilingual CMS is version 3.3.6
WPML String Translation is version 2.3.6.1
WPML Translation Management is version 2.1.5

March 3, 2016 at 5:41 am #828742

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

#1
Could you please share your debug informations with me? http://wpml.org/faq/provide-debug-information-faster-support/ I have enabled the debug form for you.

#1
Have you translated the maps page? Could you please let me know if you are using pages/widgets or theme options to insert the map?

I will wait for your feedback.

Thanks

March 3, 2016 at 1:17 pm #829173

merijnK

I have submitted debug information.

I am not using theme or page options for google maps I'm using the plugin advanced custom fields.

March 4, 2016 at 4:15 am #829715

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for getting back to us.

What about this?

Have you translated the maps page?

You should translate the page along with custom fields to make the maps visible in both languages.

You can find a detailed documentation about translating ACF fields here: https://wpml.org/documentation/theme-compatibility/setting-wpml-advanced-custom-fields/

Please let me know if you are able to translate the maps or not, i look forward to your reply.

Thanks

March 7, 2016 at 1:42 pm #831722

merijnK

I translated the maps page , but nothing changes.the maps are still not visible.

March 8, 2016 at 4:18 am #832304

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Thanks

March 8, 2016 at 12:03 pm #832705

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for the login details.

Could you please send me the link of the contact page too.

I will wait for your feedback.

Thanks

March 8, 2016 at 3:23 pm #832996

merijnK

One of the pages is hidden link and beneath in tabs is the map.

March 9, 2016 at 5:27 am #833456

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I tried to replicate the problem creating a new page but I was not able to create the exact page with tabs as you sent to me, creating new posts doesn't show maps or tabs at all.

So could you please follow the below steps:

1) Create a new page in default language.
2) Go to WPML-> Translation Management -> Multilingual Content Setup -> Custom fields translation and choose "Copy from original to translation" for the location fields.
3) Duplicate the page in both language.
4) After duplication click on the "translate independently" button and translate other texts.

Please let me know if the problem is solved, I look forward to your reply.

Thanks

March 9, 2016 at 1:47 pm #833953

merijnK

I did exactly what you said , but it didn't resolve the problem, can you give me another private message so i can send you the url of the back-end where you can see a page.

March 10, 2016 at 3:38 am #834378

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I have enabled the private form for you again. Could you please let me know how to create a fresh new page which shows maps too with steps.

I will wait for your feedback.

Thanks

March 10, 2016 at 9:35 am #834597

merijnK

From the admin panel go to for example Excursies en tickets , this is a custom post type and create a new post there , the map and tabs aren't viewed in normal posts and pages.

March 11, 2016 at 8:11 am #835503

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for the details.

Yes, I am able to replicate the problem.

There are errors on console which might be a reason of maps not rendering. So, could you please check if the error occurs when:
Please check if this issue appears when

#1
All non WPML Plugins are disabled. It will tell us if there is an interaction issue with other plugin.

#2
Theme is set to a WordPress default like Twenty Fourteen. Its will tell us if there is an interaction issue with your theme.

#3
Can you check the Chrome built-in JavaScript Console for errors. To open the console go to Menu (Three Bars) > Tools > JavaScript Console.
hidden link

Also could you please take a look at hidden link and check if you have used the required JS file properly.

I will wait for your feedback.

Thanks

March 23, 2016 at 10:03 am #844277

merijnK

I changed theme and plug-ins but i didn't solve anything.
I did how ever found this in the javascript console
At the main language the API Error: NoApiKeys is not there.

"Google Maps API warning: NoApiKeys hidden link" util.js:11:5237

"Google Maps API warning: SensorNotRequired hidden link"

But i have noticed that in the translation if some addresses are selected for the Google maps doesn't view itself but i don't understand how that is possible.

March 23, 2016 at 11:06 am #844333

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

#1
But i have noticed that in the translation if some addresses are selected for the Google maps doesn't view itself but i don't understand how that is possible.
==> Could you please explain a bit more about this?

#2
Could you please check if disabling all non-wpml plugin shows the console error? If yes, could you please activate the plugins one by one and check which plugin is creating console errors?

I will wait for your feedback

Thanks