This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by robinW-7 1 month, 3 weeks ago.

Assigned support staff: Sumit.

Author Posts
March 5, 2019 at 2:37 am #3271283

robinW-7

Hi there,

I got an error warning when I swith the setting of WPML-Settings-"How to translate posts and pages"-"New content" from "Use WPML's Classic Translation Editor" to "Use WPML's Advanced Translation Editor".

Error: No method error: undefined method `organization' for nil:NilClass

Please try again in a few minutes. If the problem persists, please contact WPML support.

And I've uploaded the screenshot of the error, could you please check this for me?

Best regards.

March 5, 2019 at 2:55 am #3271463

robinW-7

Hi, this error warning orcurred after I click the button "Synchronize translators and translation managers."

March 6, 2019 at 10:07 am #3278100

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for contacting support forum.

There might be a problem with site ID in the database that I need to check for this I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Instructions to send private information are here: hidden link

I will install adminer plugin to check the database values I hope it is fine.

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

NOTE:
Also, make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Thanks

March 7, 2019 at 9:39 am #3283239

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for the information.
I checked the login details but when I log in it says
Oops, that's not the right password. Please try again!

Could you please check the login details? I am enabling the private reply again.

Thanks

March 18, 2019 at 3:24 am #3365863

robinW-7

[data removed]

March 18, 2019 at 10:19 am #3368041

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I have adjusted the database settings for WPML. Please check the issue has been fixed.

Thanks

March 19, 2019 at 8:12 am #3376269

robinW-7

Hi,

Thank you for your work, the warning doesn't occur now. But when I do translation work in WPML-translate, the class translation editor came out instead of the advanced translation editor.
Could you please tell me how to swift to the WPML advanced translation editor?

Looking forward to your reply.Best regards.

March 19, 2019 at 12:29 pm #3378943

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Since your old content translated using Classic translated editor then when you edit the content it launches the same translation editor.
You can switch to Advanced Translation Editor but all of your existing translation will be lost.
So our recommendation keeps using Classic translation editor for old content and for new content it will automatically start Advanced Translation Editor.

Please check this article for more details https://wpml.org/documentation/translating-your-contents/translation-editor-options/

Thanks

March 27, 2019 at 1:21 am #3467193

robinW-7

My issue is resolved now. Thank you!