Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 36 replies, has 2 voices.

Last updated by Andreas W. 2 weeks, 4 days ago.

Assigned support staff: Andreas W..

Author Posts
November 4, 2019 at 10:44 am

antonS-31

I am trying to: Set Values of a gravity form to "not translated" as this may fix the issue I'm having with conditional logic.

Link to a page where the issue can be seen: hidden link
I expected to see:

Instead, I got:hidden link

As you can see form 1 isn't shown - and that's the form that's translated. I was able to translate it from the Advanced Transator, after creating a job, etc. However now it seems that I need to change the values to "do not translate".

This action is part of a wider problem I'm trying to solve - the gravity form is actually showin the conditional logic inside (visible setting, etc), but there is a strange behaviour when I submit it. The last page of the form isn't saved, even though it shown and it works as expected. It appears as if there is a handling issue when the form is parsing the entries. The result is that the fields on the last page appear empty, and also the form's conditions for the confirmation don't work, and is displaying the default confirmation. All these issues are on the ORIGINAL version of the form, not the translated.

I also have these errors when opeing the form:

[04-Nov-2019 09:22:25 UTC] PHP Notice: Undefined index: type in /home/topforma/public_html/wp-content/plugins/gravityforms-multilingual/inc/gravity-forms-multilingual.class.php on line 813
[04-Nov-2019 09:22:25 UTC] PHP Notice: Undefined index: Yes in /home/topforma/public_html/wp-content/plugins/gravityforms-multilingual/classes/class-gfml-conditional-logic.php on line 27
[04-Nov-2019 09:22:25 UTC] PHP Notice: Undefined index: wp-resetpass-468e452f7dbcb2ae6e79c4de8fb401a1 in /home/topforma/public_html/wp-content/themes/topForma/footer.php on line 3
[04-Nov-2019 09:22:25 UTC] PHP Notice: Undefined offset: 1 in /home/topforma/public_html/wp-content/themes/topForma/footer.php on line 3

November 4, 2019 at 11:55 am #4880553

antonS-31

Additional question - I see that the gravity form is under "packages" (752 strings). If I delete it, will it reset the translation of that gravity form completely?
I was hoping that original language will not be touched and the GF form will continue working while I'm traslating - but it turns out that it DOES have some effect on the original form, which is bad on a live site.

November 5, 2019 at 6:25 am #4885809

antonS-31

Additional information - after removing the package for form1, from WPML>Packages, I now see 4 strings in string translation (the form has at least 100 fields).

Unfortunately, the form is still not saving the information on the last page...

November 5, 2019 at 10:41 am #4887743

antonS-31

Further to this, I'm attaching the GF form log
Please note that the last page of the form is displayed but not saved. That's the main issue now.
All plugins are up to date
hidden link

November 5, 2019 at 12:15 pm #4888657

antonS-31

FYI, the issue is removed when I disabled WPML and the Gravity Forms Multilingual Add-on. Please advise what to do next in order to fix the issue.

November 5, 2019 at 10:42 pm #4894067

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum

The form main Questionaire was not translated yet. It further appeared as untranslated at WPML -> Translation Management -> Dashboard -> Filter for Post Type Gravity Forms.

I have created a new translation job and would kindly ask you to go to WPML -> Translations and complete the job. I have translated some strings with Google Translator as the status was still at 99% completion. Now, I reached some strings for which I am not sure of Google Translate will translate here proper. Please verify, complete the translation and let me know if the issue persists.

Please make sure to follow our documentation when it comes to translating forms.
https://wpml.org/documentation/related-projects/gravity-forms-multilingual/

I also see you are using custom fields for form shortcodes. Are you trying to translate the froms using ACF? This might work if you translate the whole filed group for each form. this way the custom field will also show up on the English Questionaire Page (backend) and you will be able to copy the shortcode.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translating-field-groups

Let me know if you need further assistance.

Kind regards
Andreas

November 6, 2019 at 6:09 am #4894919

antonS-31

Thank you Andreas.
I had deleted the package for that form, while trying different things to make the site work as it's a live site.

I have now marked the translation as complete and I went back and tested the original language and the form does indeed work as expected (data of the last page is saved). I can then go and tweak the translation.

I think the next step is to make the Domain appear in String Translation.

At the moment the breaking point is perhaps the values on the conditional fields, but again, I can't see that form in domains in String Translation...

I don't think we need ACF for anything to do with GF.

November 6, 2019 at 2:49 pm #4899453

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am not sure what happened here, but the forms are all present on String Translation. The only issue is that they do not appear in the domain dropdown filter, but if you search for the strings they show up (see screenshots).

Could you please clarify what exactly you did when you deleted the WPML Packages for Form-1? I am asking as I scanned Gravity Forms for new strings and even if the Strings are available on String Translation, some form domains will still not appear on the domain filter setting.

Kind regards
Andreas

November 6, 2019 at 5:04 pm #4900529

antonS-31

What I did it simply to delete the package gravityform1 I tthink delete is the only option on the packages menu
Please mind that the gravity forms multilingual is disabled at the moment and that's the only way I got to receive information from the last page of the form. I will try again and let you know.

Could it be that there is a specific field or value that breaks it?

November 6, 2019 at 8:13 pm #4901569

antonS-31

YOU HAVE DISABLED MY PLUGINS! Are you joking?! I have said a few times this is a live site! You can't just play with it like that. Please escalate the ticket!

November 6, 2019 at 8:25 pm #4901621

antonS-31

And I can confirm that after switching on GF multilingual - the form , again doesn't submit the last page, weirdly, still... I wish we can find a solution to this as I obviously can't use WPML at all like this.

November 6, 2019 at 10:49 pm #4902115

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry about the confusion but I did not disable any plugin.

Indeed, this is what we will need to do to find out which plugin might be causing compatibility issues together with WPML and Gravity Forms Multilingual and I would like to take a copy of your site in order to investigate. I will use a plugin called, Duplicator.

Please let me know if you do agree with that.

Further, once I find the cause of the issue I will need to see if I can recreate it with the same plugins on a new install. This way we would know that there is a compatibility between ours and a third plugin and I will be able to escalate to our compatibility team.

In case the issue will also exist on a minimal install with Gravity Forms, and WPML PLugins on default theme) and the same issue does not occur on a new install, then the problem might have been caused by a different kind of bug or user error.

As you mentioned you delete the package for gravity-form-1.

Could you please provide me more detailed steps about where exactly you deleted this package, as I can not quite follow your explication.
You can also simply test if the issue is related to your user action, by creating a new similar form and translating it. If this works out, the issue would not be related to the plugins, as they would be working as expected.

Also, please update Gravity Forms and all other plugins prior to taking any further steps, as there been updates available in the meantime.

Let me know if you agree if I take a copy of your site and I will keep debugging from there.

Kind regards
Andreas

November 7, 2019 at 5:58 am #4902827

antonS-31

Andreas
I'm ok if you make a copy of the website. As long as you delete the GF forms entries.

This is what I did to delete the package: hidden link

Deleting it didn't stop the issue - I had to disable GF multilingual in order to get all the information from the form.

November 8, 2019 at 6:14 am #4910955

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing to you to let you know that I have taken a copy of your site and until now it was quite easy to debug the site.

As far I can see there are also errors with the child theme but they seem not to be related to the Gravity Form issue. Also, it seems that something is making WPML fail to load language configuration files.

I would kindly like to ask you for some patience and I will be back with a complete report tomorrow.

I hope for your understanding.

Kind regards
Andreas

November 8, 2019 at 6:37 am #4910997

antonS-31

Thanks for the update and thanks in advance. I have just arrived at the office, so I'm available in the next 8 hours to help debug if needed.

The topic ‘[Closed] Gravity form isn't shown in String Translation’ is closed to new replies.