This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Bruno 9 months, 1 week ago.

Assigned support staff: Bruno.

Author Posts
January 17, 2019 at 2:44 pm #3102478

stephanK-2

I am trying to: upload a translation for gravity forms

Link to a page where the issue can be seen: /

I expected to see: a translated form

Instead, I got:

Fatal error: Uncaught TypeError: Argument 1 passed to WPML_Page_Builders_Page_Built::is_page_builder_page() must be an instance of WP_Post, null given, called in /var/www/nlvertaalb-gorra/wordpress/current/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/tm/class-wpml-pb-handle-post-body.php on line 33 and defined in /var/www/nlvertaalb-gorra/wordpress/current/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/utilities/class-wpml-page-builders-page-built-with-built.php:16 Stack trace: #0 /var/www/nlvertaalb-gorra/wordpress/current/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/tm/class-wpml-pb-handle-post-body.php(33): WPML_Page_Builders_Page_Built->is_page_builder_page(NULL) #1 /var/www/nlvertaalb-gorra/wordpress/current/wp-includes/class-wp-hook.php(286): WPML_PB_Handle_Post_Body->copy(false, '122', Array) #2 /var/www/nlvertaalb-gorra/wordpress/current/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #3 /var/www/nlvert in /var/www/nlvertaalb-gorra/wordpress/current/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/utilities/class-wpml-page-builders-page-built-with-built.php on line 16

January 17, 2019 at 7:24 pm #3103611

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us.

That seems to be a known problem, but at the moment we do not have a fix nor a workaround.

One of our clients created a workaround and he said it works: https://wpml.org/forums/topic/fatal-error-while-translating-gravity-form-after-upgrading-wpml/page/2/#post-3101082

Could you check if the above workaround works for you? Please, note that our developers are aware of this issue and this will be fixed in a future release.

If the problem persists, please as a test, could you disable all non-WPML plugins (keep the Gravity Forms and Gravity Forms Multilingual), switch to the default theme and see if the problem persists?

If the problem is fixed, please, enable the plugins one by one to see if there is any compatibility problem between these plugins.

Thank you.

The topic ‘[Closed] Gravity Form xliff upload 500 error’ is closed to new replies.