This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The Gravity Form doesn't work in the secondary language

Solution: Follow this steps: - Make sure that the form is correctly translated: https://wpml.org/documentation/related-projects/gravity-forms-multilingual/ - Make sure that the page is fully translated. - Go to WPML -> Support -> Troubleshooting link -> Apply the troubleshooting steps

Relevant Documentation:

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 3 weeks, 6 days ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 10, 2019 at 12:21 pm #4545275

Charles St-Pierre

I am trying to:

My form is fully functioning in original language English.
I translated the form in French through the Translation interface, up to 100%.
The French page is not translated in the front end. There is a Address field and the subfields get translated, that’s it.

It DID WORK before we updated the form.

Link to a page where the issue can be seen:

hidden link

The form IS VERY SLOW.

I expected to see:
Translated French form

Instead, I got:
Original English form

September 10, 2019 at 1:01 pm #4545531

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 11, 2019 at 8:43 pm #4556411

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

It seems that the cause of the issue is that the Form needs to update its translation. If you go to WPML -> Translation Management -> Filter by Gravity Forms you will see that the translation of the Gravity Form with ID 1 needs update.

Please finish the translation of this Form and let me know if the issue persists.

Regards,
Carlos

September 11, 2019 at 9:34 pm #4556521

Charles St-Pierre

I go to WPML -> Translation Management -> Filter by Gravity Forms
French translation says "In progress"

I go to WPML -> Translation Management -> Translation Job: filter by "Grading"

Job ID 862 is for the Gravity Form "Grading Form" and is completed 76%.

I go to WPML -> Translations queue : filter by Gravity Form.

Job ID 1404 Gravity Form - Grading Form is "In progress"

I click Translate.

The translation is 100% Complete. View the screen captures linked below.

hidden link

hidden link

Please note: The translation was done and update through File Upload XLIFF format. Because it is too huge; impossible to complete through the web interface.

September 12, 2019 at 11:56 am #4560709

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

Now I can see that the form is shown correctly (see attached image).

Could you confirm that the issue is solved?
Regards,
Carlos

September 12, 2019 at 1:38 pm #4561311

Charles St-Pierre

I need to know:

What did you do?

12 hours ago, the form was not translated.

I’m glad you solved it, but I need to know how to solve it next time.

September 12, 2019 at 2:40 pm #4561893

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

The only troubleshooting steps I ran were:
- WPML -> Support -> Troubleshooting link -> Applied the troubleshooting steps highlighted in the attached image.

Regards,
Carlos

September 15, 2019 at 3:56 am #4573887

Charles St-Pierre

My issue is resolved now. Thank you!

Although I don't fully understand what could have caused the problem.

September 16, 2019 at 9:55 am #4578287

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos