This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bigul 3 years, 8 months ago.

Assigned support staff: Bigul.

Author Posts
October 26, 2016 at 9:22 pm #1123995

Nina Gonzalez

I am trying to: Make changes to Gravity Forms.

URL of (my) website where problem appears: earthcharter.org

I expected to see: the changes are saved

Instead, I got: browser timeout

Steps to duplicate the issue: Open a gravity form and click the save button. Nine times out of ten, the browser will time out. One out of ten it will save after 3 to 4 minutes. But for most forms, we are unable to make changes. We have been able to determine that the problem is with Gravity Forms Multilingual. When we turn off this plugin, we can make changes and it is very fast.

October 27, 2016 at 10:48 am #1124334

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for contacting the WPML support. We are happy to help you.

Please enable debug mode by adding following code in wp-config.php file of your site and confirm you are getting any PHP or JavaScript warnings or errors related to WPML and Gravity Forms Multilingual while saving the Gravity Forms.

 // Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

Please check following tutorials for getting more information about debugging with WordPress.

https://codex.wordpress.org/Debugging_in_WordPress

https://codex.wordpress.org/Debugging_in_WordPress#Example_wp-config.php_for_Debugging

If possible, please deactivate other plugins(after a full site backup) except WPML ones and Gravity forms and check the issue is exists or not.

--
With Regards

Bigul

October 27, 2016 at 8:47 pm #1124809

Nina Gonzalez

We turned on debug, but did not get any information about Gravity Forms or Gravity Forms Multilingual. We are unable to replicate the problem on our staging server, but can't find the problem on our Production Server.

October 28, 2016 at 7:21 am #1124951

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for the details. I have few more questions and requests.

1) Does it happen to all the Gravity forms, or only it happens with a specific one ? If it is happening to a specific form, which kinds of fields you are using for it ?

2) Does it happen after any recent upgrade to changes ?

Please do the following after a full site backup and let me know your feedback.

1) Increase the WP Memory limit to 128 MB or 256 MB. Check following tutorial for more details about increasing the WP Memory limit.

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Increase the *MaxInputVars* of your PHP settings from *1000* to *5000* or more. Hope the following tutorials will help you.

hidden link

hidden link

3) Increase the *TimeLimit* from *30* seconds to *120* seconds. Check following tutorials for more details.

hidden link

hidden link

4) Then try to save the forms.

5) If the issue exists check your browser console and confirm you are getting any JavaScript errors while saving the forms ?

--
With Regards

Bigul

The topic ‘[Closed] Gravity Forms Multilingual Plugin prevents any changes to existing forms’ is closed to new replies.