Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bruno Kos 3 weeks, 1 day ago.

Assigned support staff: Bruno Kos.

Author Posts
November 14, 2019 at 8:33 am #4944613

w.h.K

I am trying to: Translate a form field with stringtranslations

Link to a page where the issue can be seen:hidden link

I expected to see: The white text under Permissions* should be translated but it's not showing up in stringtranslations anymore.

Instead, I got:

November 14, 2019 at 9:06 am #4944805

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

Can you please try this?
https://wpml.org/errata/in-some-cases-some-strings-are-not-translating-properly/

Specifically this:

- Go to the WPML -> String Translation page and in the Auto register strings for translation section, enable the Look for strings while pages are rendered option.
- Re-visit the page on the front-end where the string appears.
- Re-visit the WPML -> String Translation page and search for that string.
- Translate the string.
- After translating the string, remember to un-check the auto-registration option.

Does it work? If not, can you tell me what type of the field is it?

Regards,
Bruno Kos

November 15, 2019 at 8:44 am #4951927

w.h.K

Hi Bruno,

I already did try exactly that and just did it again to be sure. But that's not working.

It's a GravityForms > Checkboxes > Description field. (but I think many more fields in GravityForms)

November 15, 2019 at 8:50 am #4951989

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I see - what happens when you try the following:
https://wpml.org/documentation/related-projects/gravity-forms-multilingual/#updating-forms-translation

Because please have a look at this:
https://wpml.org/forums/topic/my-custom-gravity-forms-not-appearing-in-the-string-translations/#post-4913685

Especially this part:
"In WPML 4.3.0 we filtered out those package strings in WPML > String Translation because it was not supposed to be edited there and it was bloating the string list."

According to our internal system ticket, the fix for this is going into string translation 3.0.4.

Regards,
Bruno Kos

November 15, 2019 at 9:50 am #4952391

w.h.K

Hi Bruno,

I managed to follow the steps and now i'm much further. But after translating all fields it keeps saying 0% complete and the translated values are not showing on the front-end.

November 15, 2019 at 9:55 am #4952431

w.h.K

Sorry my bad need to check the Translation is complete fields.

November 15, 2019 at 10:18 am #4952577

w.h.K

Hi Bruno,

Locally is everything working fine now. And live site it's working if I do not choose different domain per language.

Check screenshots. So it's something with the different domain per language settings.

One is with .nl and .com and one is with /en/ .

November 15, 2019 at 10:38 am #4952855

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Is this happening on your production site if you change language url format? What about caching, do you have server-side or site caching you can clear?

What is the URL where I can see the form currently?

Regards,
Bruno Kos

The topic ‘[Closed] Gravity Forms Multilingual stopped working also after update to 4.3.3’ is closed to new replies.