Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Dražen Duvnjak 2 months ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
December 21, 2020 at 11:43 pm #7712433


I have submitted a translation request to myself and updated all the translations for our Spanish versions of the form. I have taken screenshots indicating the form we are using, showing the translations that I did using the advanced Editor but when I navigate to the Spanish version of the page with the /es modifier I'm not seeing the translated text. I have redacted some personal information from my screenshots but showing the status indicated that the translations were completed and there is no current jobs to "retrieve" since I have already done so.

I'm not sure why Im unable to see the Spanish version of the translated content.

We have a known plugin conflict which the way to work around this is de-activate all plugins on the entire site expect those related to only WPML and to retrieve the translations which I have already done.

Any thought on how to resolve this issue?

Also how do we make these types of support requests private? It makes it challenging to post sensitive information which requires me to do a ton of redactions on my images...


December 23, 2020 at 1:24 pm #7724093


Is there anyway to get this reviewed? This ticket is now almost 2 days old and I have not seen a response

December 23, 2020 at 1:37 pm #7724165

Dražen Duvnjak

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)


sorry for waiting, I have just taken your ticket and preparing a reply.

Can you please follow the next steps and let me know how it goes:

1) In order to expedite handling your support requests, can you please share WPML support debug information from your site.

- To give debug information, login to your site and go to WPML → Support. From there click on the “debug information” link at the bottom of the page.
- Once on the “debug information” page, select the entire content of the text box and copy it.
- Now go back to our support forum, find debug information box and paste it.

More information on the link:

2) Please try the next steps:

- Disable all other plugins and leave active only WPML plugins and Gravity forms. Switch to WP default theme.
- Go to your default language form and make a small change inside form fields, save.
- Go to WPML > Translation Management and send the form to the local translation
- Go to WPML > Translation, take and translate it 100%
- Check if the issue still happens.

- Create a new test page and add your form to it.
- Translate the page and check if the form is showing translated on the translated page.

Please let me know how it goes and don't hesitate to ask if you find any problem along the way or have doubts or questions about the steps mentioned above, I'll do my best to help you in the best way possible.


December 23, 2020 at 2:09 pm #7724475


I have copied out the debug information and pasted it into the text box.

I have also tried as well to disable all plugins except for Gravity forms and WPML to attempt to get this to fire correctly but I'm not able to see the expected result.

Please let me know how to proceed from here

December 23, 2020 at 2:44 pm #7724867

Dražen Duvnjak

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)


thanks for the feedback.

1) I see you are using an older version of WPML plugins (4.4.8.) and Gravity forms (2.4.22). Please make a backup and update the plugins to the latest versions.


I also do not see the Gravity Forms Multilingual add-on, so please make sure the latest version is installed and activated.


2) After updating to the latest versions and installing Gravity Forms Multilingual, please follow my suggestion steps from the previous reply and let me know what happens for each testing case.

3) Please also try, to duplicate the form to a new form and then translate it. Add a new form to your page and save. Update the page translation. Does it now show correctly on the translated page?

Please try to follow each of my suggested steps and let me know how it goes for each.

Thanks and kind regards,

The topic ‘[Closed] Gravity Forms not translating even thought job is completed’ is closed to new replies.