This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by patrickH-4 3 weeks, 3 days ago.

Assigned support staff: Sumit.

Author Posts
September 18, 2019 at 6:40 pm #4599539

patrickH-4

I am trying to: get radio buttons to translate to english from french

Link to a page where the issue can be seen: hidden link

I expected to see: english options on the values

Instead, I got: french values

September 19, 2019 at 1:15 pm #4605097

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for contacting support forum.

I am assuming you have downloaded and activated Gravity form Multilingual https://wpml.org/download/gravityforms-multilingual/?section=changelog and running all latest version of plugins. If yes then please make sure you are following this guide https://wpml.org/documentation/related-projects/gravity-forms-multilingual/

If everything is okay then please make a small change to the form and send for translation again, do you see the choice labels in translation editor? If yes then please translate if not then, please let me know.

Also, please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

Thanks

September 19, 2019 at 2:24 pm #4606247

patrickH-4

I noticed that the plugins weren't updated, I updated evrything and followed the steps in the link https://wpml.org/documentation/related-projects/gravity-forms-multilingual/ but now, the whole form shows up in french

September 20, 2019 at 12:49 pm #4612227

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

It is possible that strings need update due to some minor changes in the form.

Could you please follow these steps:-
#1 Can you please disable all plugins those are unrelated with WPML except gravity forms and switch to one of the default themes e.g. Twenty Fifteen
#2 Edit the form and update without any change.
#3 From the top admin bar you can send the form again for translation.
#4 Go the translation and make sure all the strings are translated then save the translation and please check on front-end.

Does it fix the issue?

NOTE:
Also make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Thanks

September 20, 2019 at 4:39 pm #4613611

patrickH-4

no it did not, it is still showing all french

September 20, 2019 at 10:09 pm #4614455

patrickH-4

My issue is resolved now. Thank you! I duplicated the form and sent it to translation and everything now is working fine.